p PatchFirst

PatchFirst · Latest vulnerabilities

ffmpeg vulnerabilities · Page 22

Vulnerabilities published for ffmpeg in the last 30 days: 10. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 433

  1. CVE-2009-4635

    Not ratedEPSS 8.06%Fix available

    CVE-2009-4635

    FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

    • Update to 4:0.5+svn20090706-3
    Published Updated
  2. CVE-2009-4634

    Not ratedEPSS 7.15%Fix available

    CVE-2009-4634

    Multiple integer underflows in FFmpeg 0.5 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted file that (1) bypasses a validation check in vorbis_dec.c and triggers a wraparound of the stack pointer, or (2) access a pointer from out-of-bounds memory in mov.c, related to an elst tag that appears before a tag that creates a stream.

    • Update to 4:0.5+svn20090706-3
    Published Updated
  3. CVE-2009-4633

    Not ratedEPSS 7.88%Fix available

    CVE-2009-4633

    vorbis_dec.c in FFmpeg 0.5 uses an assignment operator when a comparison operator was intended, which might allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted file that modifies a loop counter and triggers a heap-based buffer overflow.

    • Update to 4:0.5+svn20090706-3
    Published Updated
  4. CVE-2008-3162

    Not ratedEPSS 9.25%Public exploitFix available

    CVE-2008-3162

    Stack-based buffer overflow in the str_read_packet function in libavformat/psxstr.c in FFmpeg before r13993 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted STR file that interleaves audio and video sectors.

    • Update to 0.svn20080206-10
    Published Updated
  5. CVE-2006-4800

    Not ratedEPSS 5.3%Fix available

    CVE-2006-4800

    Multiple buffer overflows in libavcodec in ffmpeg before 0.4.9_p20060530 allow remote attackers to cause a denial of service or possibly execute arbitrary code via multiple unspecified vectors in (1) dtsdec.c, (2) vorbis.c, (3) rm.c, (4) sierravmd.c, (5) smacker.c, (6) tta.c, (7) 4xm.c, (8) alac.c, (9) cook.c, (10) shorten.c, (11) smacker.c, (12) snow.c, and (13) tta.c. NOTE: it is likely that this is a different vulnerability than CVE-2005-4048 and CVE-2006-2802.

    • Update to 0.cvs20060329-1
    Published Updated
  6. CVE-2005-4048

    Not ratedEPSS 5.21%Fix available

    CVE-2005-4048

    Heap-based buffer overflow in the avcodec_default_get_buffer function (utils.c) in FFmpeg libavcodec 0.4.9-pre1 and earlier, as used in products such as (1) mplayer, (2) xine-lib, (3) Xmovie, and (4) GStreamer, allows remote attackers to execute arbitrary commands via small PNG images with palettes.

    • Update to 0.cvs20050918-5.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →