p PatchFirst

PatchFirst · Latest vulnerabilities

openjpeg2 vulnerabilities · Page 4

Vulnerabilities published for openjpeg2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 78

  1. CVE-2016-8332

    High · CVSS 7.5EPSS 2.56%Fix available

    CVE-2016-8332

    A buffer overflow in OpenJPEG 2.1.1 causes arbitrary code execution when parsing a crafted image. An exploitable code execution vulnerability exists in the jpeg2000 image file format parser as implemented in the OpenJpeg library. A specially crafted jpeg2000 file can cause an out of bound heap write resulting in heap corruption leading to arbitrary code execution. For a successful attack, the target user needs to open a malicious jpeg2000 file. The jpeg2000 image file format is mostly used for embedding images inside PDF documents and the OpenJpeg library is used by a number of popular PDF renderers making PDF documents a likely attack vector

    • Update to 2.1.2-1
    Published Updated
  2. CVE-2016-5159

    High · CVSS 8.8EPSS 1.96%Fix available

    CVE-2016-5159

    Multiple integer overflows in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data that is mishandled during opj_aligned_malloc calls in dwt.c and t1.c.

    • Update to 2.1.2-1
    Published Updated
  3. CVE-2016-5158

    High · CVSS 8.8EPSS 1.54%Fix available

    CVE-2016-5158

    Multiple integer overflows in the opj_tcd_init_tile function in tcd.c in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data.

    • Update to 2.1.2-1
    Published Updated
  4. CVE-2016-5157

    High · CVSS 8.8EPSS 4.7%Fix available

    CVE-2016-5157

    Heap-based buffer overflow in the opj_dwt_interleave_v function in dwt.c in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allows remote attackers to execute arbitrary code via crafted coordinate values in JPEG 2000 data.

    • Update to 2.1.2-1
    Published Updated
  5. CVE-2016-5152

    High · CVSS 8.8EPSS 1.64%Fix available

    CVE-2016-5152

    Integer overflow in the opj_tcd_get_decoded_tile_size function in tcd.c in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data.

    • Update to 2.1.2-1.2
    Published Updated
  6. CVE-2016-5139

    High · CVSS 7.6EPSS 1.28%Fix available

    CVE-2016-5139

    Multiple integer overflows in the opj_tcd_init_tile function in tcd.c in OpenJPEG, as used in PDFium in Google Chrome before 52.0.2743.116, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data.

    • Update to 2.1.2-1
    Published Updated
  7. CVE-2016-1628

    Medium · CVSS 6.3EPSS 1.88%Fix available

    CVE-2016-1628

    pi.c in OpenJPEG, as used in PDFium in Google Chrome before 48.0.2564.109, does not validate a certain precision value, which allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds read) via a crafted JPEG 2000 image in a PDF document, related to the opj_pi_next_rpcl, opj_pi_next_pcrl, and opj_pi_next_cprl functions.

    • Update to 2.1.2-1.2
    Published Updated
  8. CVE-2015-6581

    Not ratedEPSS 2.68%Fix available

    CVE-2015-6581

    Double free vulnerability in the opj_j2k_copy_default_tcp_and_create_tcd function in j2k.c in OpenJPEG before r3002, as used in PDFium in Google Chrome before 45.0.2454.85, allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) by triggering a memory-allocation failure.

    • Update to 2.1.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →