p PatchFirst

PatchFirst · Latest vulnerabilities

poppler vulnerabilities · Page 2

Vulnerabilities published for poppler in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 141

  1. CVE-2022-37050

    Medium · CVSS 6.5EPSS 1.08%Fix available

    CVE-2022-37050

    In Poppler 22.07.0, PDFDoc::savePageAs in PDFDoc.c callows attackers to cause a denial-of-service (application crashes with SIGABRT) by crafting a PDF file in which the xref data structure is mishandled in getCatalog processing. Note that this vulnerability is caused by the incomplete patch of CVE-2018-20662.

    • Update to 22.08.0-2
    Published Updated
  2. CVE-2022-38784

    High · CVSS 7.8EPSS 0.63%Fix available

    CVE-2022-38784

    Poppler prior to and including 22.08.0 contains an integer overflow in the JBIG2 decoder (JBIG2Stream::readTextRegionSeg() in JBIGStream.cc). Processing a specially crafted PDF file or JBIG2 image could lead to a crash or the execution of arbitrary code. This is similar to the vulnerability described by CVE-2022-38171 in Xpdf.

    • Update to 22.08.0-2.1
    Published Updated
  3. CVE-2019-9959

    Medium · CVSS 6.5EPSS 1.91%Fix available

    CVE-2019-9959

    The JPXStream::init function in Poppler 0.78.0 and earlier doesn't check for negative values of stream length, leading to an Integer Overflow, thereby making it possible to allocate a large memory chunk on the heap, with a size controlled by an attacker, as demonstrated by pdftocairo.

    • Update to 0.85.0-2
    Published Updated
  4. CVE-2019-12957

    High · CVSS 7.8EPSS 1.23%Fix available

    CVE-2019-12957

    In Xpdf 4.01.01, a buffer over-read could be triggered in FoFiType1C::convertToType1 in fofi/FoFiType1C.cc when the index number is larger than the charset array bounds. It can, for example, be triggered by sending a crafted PDF document to the pdftops tool. It allows an attacker to use a crafted pdf file to cause Denial of Service or an information leak, or possibly have unspecified other impact.

    • Update to 0.22.5-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →