p PatchFirst

PatchFirst · Latest vulnerabilities

unbound vulnerabilities · Page 4

Vulnerabilities published for unbound in the last 30 days: 5. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 87

  1. CVE-2022-30699

    Medium · CVSS 6.5EPSS 1.16%Fix available

    Novel "ghost domain names" attack by updating almost expired delegation information

    NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on

    • Update to 1.16.2-1
    Published Updated
  2. CVE-2022-30698

    Medium · CVSS 6.5EPSS 1.16%Fix available

    Novel "ghost domain names" attack by introducing subdomain delegations

    NLnet Labs Unbound, up to and including version 1.16.1 is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a subdomain of a rogue domain name. The rogue nameserver returns delegation information for the subdomain that updates Unbound's delegation cache. This action can be repeated before expiry of the delegation information by querying Unbound for a second level subdomain which the rogue nameserver provides new delegation information. Since Unbound is a child-centric resolver, the ever-updating child delegation information can keep a rogue domain na

    • Update to 1.16.2-1
    Published Updated
  3. CVE-2019-25031

    Medium · CVSS 5.9EPSS 1.68%Fix available

    CVE-2019-25031

    Unbound before 1.9.5 allows configuration injection in create_unbound_ad_servers.sh upon a successful man-in-the-middle attack against a cleartext HTTP session. NOTE: The vendor does not consider this a vulnerability of the Unbound software. create_unbound_ad_servers.sh is a contributed script from the community that facilitates automatic configuration creation. It is not part of the Unbound installation

    • Update to 1.9.6-1
    Published Updated
  4. CVE-2019-25034

    Critical · CVSS 9.8EPSS 2.88%Fix available

    CVE-2019-25034

    Unbound before 1.9.5 allows an integer overflow in sldns_str2wire_dname_buf_origin, leading to an out-of-bounds write. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited

    • Update to 1.9.6-1
    Published Updated
  5. CVE-2020-28935

    Medium · CVSS 5.5EPSS 0.49%Fix available

    Local symlink attack in Unbound and NSD

    NLnet Labs Unbound, up to and including version 1.12.0, and NLnet Labs NSD, up to and including version 4.3.3, contain a local vulnerability that would allow for a local symlink attack. When writing the PID file, Unbound and NSD create the file if it is not there, or open an existing file for writing. In case the file was already present, they would follow symlinks if the file happened to be a symlink instead of a regular file. An additional chown of the file would then take place after it was written, making the user Unbound/NSD is supposed to run as the new owner of the file. If an attacker has local access to the user Unbound/NSD runs as,

    • Update to 1.13.0-1
    Published Updated
  6. CVE-2019-18934

    High · CVSS 7.3EPSS 3.2%Fix available

    CVE-2019-18934

    Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.

    • Update to 1.9.6-1
    Published Updated
  7. CVE-2017-15105

    Medium · CVSS 5.3EPSS 3.16%Fix available

    CVE-2017-15105

    A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound into accepting a NODATA proof.

    • Update to 1.7.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →