p PatchFirst

PatchFirst · Latest vulnerabilities

wireshark vulnerabilities · Page 31

Vulnerabilities published for wireshark in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 756

  1. CVE-2012-4293

    Not ratedEPSS 1.19%Fix available

    CVE-2012-4293

    plugins/ethercat/packet-ecatmb.c in the EtherCAT Mailbox dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 does not properly handle certain integer fields, which allows remote attackers to cause a denial of service (application exit) via a malformed packet.

    • Update to 1.8.2-1
    Published Updated
  2. CVE-2012-4292

    Not ratedEPSS 1.91%Fix available

    CVE-2012-4292

    The dissect_stun_message function in epan/dissectors/packet-stun.c in the STUN dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 does not properly interact with key-destruction behavior in a certain tree library, which allows remote attackers to cause a denial of service (application crash) via a malformed packet.

    • Update to 1.8.2-1
    Published Updated
  3. CVE-2012-4288

    Not ratedEPSS 1.94%Fix available

    CVE-2012-4288

    Integer overflow in the dissect_xtp_ecntl function in epan/dissectors/packet-xtp.c in the XTP dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (loop or application crash) via a large value for a span length.

    • Update to 1.8.2-1
    Published Updated
  4. CVE-2012-4285

    Not ratedEPSS 2.08%Fix available

    CVE-2012-4285

    The dissect_pft function in epan/dissectors/packet-dcp-etsi.c in the DCP ETSI dissector in Wireshark 1.4.x before 1.4.15, 1.6.x before 1.6.10, and 1.8.x before 1.8.2 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a zero-length message.

    • Update to 1.8.2-1
    Published Updated
  5. CVE-2012-2394

    Not ratedEPSS 3.88%Public exploitFix available

    CVE-2012-2394

    Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 on the SPARC and Itanium platforms does not properly perform data alignment for a certain structure member, which allows remote attackers to cause a denial of service (application crash) via a (1) ICMP or (2) ICMPv6 Echo Request packet.

    • Update to 1.6.8-1
    Published Updated
  6. CVE-2012-2393

    Not ratedEPSS 3.73%Public exploitFix available

    CVE-2012-2393

    epan/dissectors/packet-diameter.c in the DIAMETER dissector in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 does not properly construct certain array data structures, which allows remote attackers to cause a denial of service (application crash) via a crafted packet that triggers incorrect memory allocation.

    • Update to 1.6.8-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →