p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 3

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 165

  1. CVE-2023-28879

    Critical · CVSS 9.8EPSS 6.34%Fix available

    CVE-2023-28879

    In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

    • Update to 10.0.0~dfsg-11
    Published Updated
  2. CVE-2020-27792

    High · CVSS 7.1EPSS 0.47%Fix available

    Ghostscript: heap buffer over write vulnerability in ghostscript's lp8000_print_page() in gdevlp8k.c

    A heap-based buffer overwrite vulnerability was found in GhostScript's lp8000_print_page() function in the gdevlp8k.c file. This flaw allows an attacker to trick a user into opening a crafted PDF file, triggering the heap buffer overflow that could lead to memory corruption or a denial of service.

    • Update to 9.51~dfsg-1
    Published Updated
  3. CVE-2022-2085

    Medium · CVSS 5.5EPSS 1.41%Fix available

    CVE-2022-2085

    A NULL pointer dereference vulnerability was found in Ghostscript, which occurs when it tries to render a large number of bits in memory. When allocating a buffer device, it relies on an init_device_procs defined for the device that uses it as a prototype that depends upon the number of bits per pixel. For bpp > 64, mem_x_device is used and does not have an init_device_procs defined. This flaw allows an attacker to parse a large number of bits (more than 64 bits per pixel), which triggers a NULL pointer dereference flaw, causing an application to crash.

    • Update to 9.56.0~dfsg-1
    Published Updated
  4. CVE-2022-1350

    Medium · CVSS 4.3EPSS 0.84%Fix available

    GhostPCL gsmchunk.c chunk_free_object memory corruption

    A vulnerability classified as problematic was found in GhostPCL 9.55.0. This vulnerability affects the function chunk_free_object of the file gsmchunk.c. The manipulation with a malicious file leads to a memory corruption. The attack can be initiated remotely but requires user interaction. The exploit has been disclosed to the public as a POC and may be used. It is recommended to apply the patches to fix this issue.

    • Update to 10.0.0~dfsg-3
    Published Updated
  5. CVE-2021-3781

    Critical · CVSS 9.9EPSS 83.91%Fix available

    CVE-2021-3781

    A trivial sandbox (enabled with the `-dSAFER` option) escape flaw was found in the ghostscript interpreter by injecting a specially crafted pipe command. This flaw allows a specially crafted document to execute arbitrary commands on the system in the context of the ghostscript interpreter. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 9.53.3~dfsg-8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →