p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 4

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 165

  1. CVE-2020-15900

    Critical · CVSS 9.8EPSS 5.19%Fix available

    CVE-2020-15900

    A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The 'rsearch' calculation for the 'post' size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

    • Update to 9.52.1~dfsg-1
    Published Updated
  2. CVE-2019-14812

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  3. CVE-2019-10216

    High · CVSS 7.3EPSS 2.3%Fix available

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Update to 9.27~dfsg-3.1
    Published Updated
  4. CVE-2019-14869

    High · CVSS 7.3EPSS 3.09%Fix available

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Update to 9.50~dfsg-3
    Published Updated
  5. CVE-2019-14813

    High · CVSS 7.3EPSS 10.96%Fix available

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →