p PatchFirst

PatchFirst · Latest vulnerabilities

imagemagick vulnerabilities · Page 18

Vulnerabilities published for imagemagick in the last 30 days: 84. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 866

  1. CVE-2020-10251

    Medium · CVSS 5.5EPSS 1.53%Fix available

    CVE-2020-10251

    In ImageMagick 7.0.9, an out-of-bounds read vulnerability exists within the ReadHEICImageByID function in coders\heic.c. It can be triggered via an image with a width or height value that exceeds the actual size of the image.

    • Update to 8:6.9.11.24+dfsg-1
    Published Updated
  2. CVE-2014-1947

    High · CVSS 7.8EPSS 7.02%Public exploitFix available

    CVE-2014-1947

    Stack-based buffer overflow in the WritePSDImage function in coders/psd.c in ImageMagick 6.5.4 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large number of layers in a PSD image, involving the L%02ld string, a different vulnerability than CVE-2014-2030.

    • Update to 8:6.7.7.10+dfsg-1
    Published Updated
  3. CVE-2014-2030

    High · CVSS 8.8EPSS 11.05%Public exploitFix available

    CVE-2014-2030

    Stack-based buffer overflow in the WritePSDImage function in coders/psd.c in ImageMagick, possibly 6.8.8-5, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PSD image, involving the L%06ld string, a different vulnerability than CVE-2014-1947.

    • Update to 8:6.7.7.10+dfsg-1
    Published Updated
  4. CVE-2019-15139

    Medium · CVSS 6.5EPSS 3.5%Fix available

    CVE-2019-15139

    The XWD image (X Window System window dumping file) parsing component in ImageMagick 7.0.8-41 Q16 allows attackers to cause a denial-of-service (application crash resulting from an out-of-bounds Read) in ReadXWDImage in coders/xwd.c by crafting a corrupted XWD image file, a different vulnerability than CVE-2019-11472.

    • Update to 8:6.9.11.24+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →