p PatchFirst

PatchFirst · Latest vulnerabilities

lighttpd vulnerabilities · Page 2

Vulnerabilities published for lighttpd in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 37

  1. CVE-2009-3555

    Critical · CVSS 9.8EPSS 87.26%Public exploitFix available

    CVE-2009-3555

    The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft Internet Information Services (IIS) 7.0, mod_ssl in the Apache HTTP Server 2.2.14 and earlier, OpenSSL before 0.9.8l, GnuTLS 2.8.5 and earlier, Mozilla Network Security Services (NSS) 3.12.4 and earlier, multiple Cisco products, and other products, does not properly associate renegotiation handshakes with an existing connection, which allows man-in-the-middle attackers to insert data into HTTPS sessions, and possibly other types of sessions protected by TLS or SSL, by sending an unauthenticated request that is processed retroactively by a server in a post-re

    • Update to 1.4.30-1
    Published Updated
  2. CVE-2008-4360

    Not ratedEPSS 4.35%Fix available

    CVE-2008-4360

    mod_userdir in lighttpd before 1.4.20, when a case-insensitive operating system or filesystem is used, performs case-sensitive comparisons on filename components in configuration options, which might allow remote attackers to bypass intended access restrictions, as demonstrated by a request for a .PHP file when there is a configuration rule for .php files.

    • Update to 1.4.19-5
    Published Updated
  3. CVE-2008-1531

    Not ratedEPSS 3.37%Fix available

    CVE-2008-1531

    The connection_state_machine function (connections.c) in lighttpd 1.4.19 and earlier, and 1.5.x before 1.5.0, allows remote attackers to cause a denial of service (active SSL connection loss) by triggering an SSL error, such as disconnecting before a download has finished, which causes all active SSL connections to be lost.

    • Update to 1.4.19-2
    Published Updated
  4. CVE-2007-4727

    Not ratedEPSS 12.9%Fix available

    CVE-2007-4727

    Buffer overflow in the fcgi_env_add function in mod_proxy_backend_fastcgi.c in the mod_fastcgi extension in lighttpd before 1.4.18 allows remote attackers to overwrite arbitrary CGI variables and execute arbitrary code via an HTTP request with a long content length, as demonstrated by overwriting the SCRIPT_FILENAME variable, aka a "header overflow."

    • Update to 1.4.18-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →