p PatchFirst

PatchFirst · Latest vulnerabilities

@sveltejs/adapter-node vulnerabilities

Vulnerabilities published for @sveltejs/adapter-node in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2025-67647

    High · CVSS 8.4EPSS 0.52%Fix available

    SvelteKit Denial of service and possible SSRF when using prerendering

    SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. T

    • Update to 5.5.1
    Published Updated
  2. CVE-2024-23641

    High · CVSS 7.5EPSS 0.76%Fix available

    Sending a GET or HEAD request with a body crashes SvelteKit

    SvelteKit is a web development kit. In SvelteKit 2, sending a GET request with a body eg `{}` to a built and previewed/hosted sveltekit app throws `Request with GET/HEAD method cannot have body.` and crashes the preview/hosting. After this happens, one must manually restart the app. `TRACE` requests will also cause the app to crash. Prerendered pages and SvelteKit 1 apps are not affected. `@sveltejs/adapter-node` versions 2.1.2, 3.0.3, and 4.0.1 and `@sveltejs/kit` version 2.4.3 contain a patch for this issue.

    • Update to 2.1.2
    • Update to 3.0.3
    • Update to 4.0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →