p PatchFirst

PatchFirst · Latest vulnerabilities

flowise-components vulnerabilities · Page 2

Vulnerabilities published for flowise-components in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2026-41271

    High · CVSS 7.1EPSS 0.23%Fix available

    Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  2. CVE-2026-41272

    High · CVSS 7.1EPSS 0.26%Fix available

    Flowise: SSRF Protection Bypass (TOCTOU & Default Insecure)

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the core security wrappers (secureAxiosRequest and secureFetch) intended to prevent Server-Side Request Forgery (SSRF) contain multiple logic flaws. These flaws allow attackers to bypass the allow/deny lists via DNS Rebinding (Time-of-Check Time-of-Use) or by exploiting the default configuration which fails to enforce any deny list. This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  3. CVE-2026-41270

    High · CVSS 7.1EPSS 0.23%Fix available

    Flowise: SSRF Protection Bypass via Unprotected Built-in HTTP Modules in Custom Function Sandbox

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) protection bypass vulnerability exists in the Custom Function feature. While the application implements SSRF protection via HTTP_DENY_LIST for axios and node-fetch libraries, the built-in Node.js http, https, and net modules are allowed in the NodeVM sandbox without equivalent protection. This allows authenticated users to bypass SSRF controls and access internal network resources (e.g., cloud provider metadata services) This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  4. CVE-2026-41268

    High · CVSS 7.7EPSS 17.44%Fix available

    Flowise: Flowise Parameter Override Bypass Remote Command Execution

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  5. CVE-2026-41137

    Critical · CVSS 9.4EPSS 1.45%Fix available

    Flowise: Code Injection in CSVAgent leads to Authenticated RCE

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, The CSVAgent allows providing a custom Pandas CSV read code. Due to lack of sanitization, an attacker can provide a command injection payload that will get interpolated and executed by the server. This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  6. CVE-2026-41138

    High · CVSS 8.3EPSS 0.6%Fix available

    Flowise: Remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas.

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.

    • Update to 3.1.0
    Published Updated
  7. CVE-2026-40933

    Critical · CVSS 10EPSS 11.96%Fix available

    Flowise: Authenticated RCE Via MCP Adapters

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, due to unsafe serialization of stdio commands in the MCP adapter, an authenticated attacker can add an MCP stdio server with an arbitrary command, achieving command execution. The vulnerability lies in a bug in the input sanitization from the “Custom MCP” configuration in http://localhost:3000/canvas - where any user can add a new MCP, when doing so - adding a new MCP using stdio, the user can add any command, even though your code have input sanitization checks such as validateCommandInjection and validateArgsForLocalFileAccess, and a lis

    • Update to 3.1.0
    Published Updated
  8. CVE-2026-31829

    High · CVSS 7.1EPSS 2.44%Fix available

    Flowise affected by Server-Side Request Forgery (SSRF) in HTTP Node Leading to Internal Network Access

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.0.13, Flowise exposes an HTTP Node in AgentFlow and Chatflow that performs server-side HTTP requests using user-controlled URLs. By default, there are no restrictions on target hosts, including private/internal IP ranges (RFC 1918), localhost, or cloud metadata endpoints. This enables Server-Side Request Forgery (SSRF), allowing any user interacting with a publicly exposed chatflow to force the Flowise server to make requests to internal network resources that are inaccessible from the public internet. This vulnerability is fixed in 3.0.13.

    • Update to 3.0.13
    Published Updated
  9. GHSA-j44m-5v8f-gc9c

    High · CVSS 7.7Fix available

    Flowise is vulnerable to arbitrary file exposure through its ReadFileTool

    ### Summary The ReadFileTool in Flowise does not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read arbitrary files from the file system, potentially leading to remote command execution. ### Details Flowise supports providing ReadFileTool for large models to read files in the server's file system. The implementation of this tool is located at packages/components/nodes/tools/ReadFile/ReadFile.ts. ``` /** * Class for reading files from the disk. Extends the StructuredTool * class. */ export class ReadFileTool extends StructuredTool { static lc_name() { return 'ReadFileTool' }

    • Update to 3.0.8
    Published Updated
  10. CVE-2025-61913

    Critical · CVSS 10EPSS 12.95%Fix available

    Flowise is vulnerable to arbitrary file read, arbitrary file write

    Flowise is a drag & drop user interface to build a customized large language model flow. In versions prior to 3.0.8, WriteFileTool and ReadFileTool in Flowise do not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read and write arbitrary files to any path in the file system, potentially leading to remote command execution. Flowise 3.0.8 fixes this vulnerability.

    • Update to 3.0.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →