p PatchFirst

PatchFirst · Latest vulnerabilities

flowise vulnerabilities · Page 6

Vulnerabilities published for flowise in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 114

  1. CVE-2025-58434

    Critical · CVSS 9.8EPSS 50.54%Public exploitFix available

    Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5 and earlier, the `forgot-password` endpoint in Flowise returns sensitive information including a valid password reset `tempToken` without authentication or verification. This enables any attacker to generate a reset token for arbitrary users and directly reset their password, leading to a complete account takeover (ATO). This vulnerability applies to both the cloud service (`cloud.flowiseai.com`) and self-hosted/local Flowise deployments that expose the same API. Commit 9e178d68873eb876073846433a596590d3d9c863 in version 3.0.6 secures pas

    • Update to 3.0.6
    Published Updated
  2. CVE-2025-8943

    Critical · CVSS 9.8EPSS 75.2%Public exploitNo fix published

    Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers

    The Custom MCPs feature is designed to execute OS commands, for instance, using tools like `npx` to spin up local MCP Servers. However, Flowise's inherent authentication and authorization model is minimal and lacks role-based access controls (RBAC). Furthermore, in Flowise versions before 3.0.1 the default installation operates without authentication unless explicitly configured. This combination allows unauthenticated network attackers to execute unsandboxed OS commands.

    Published Updated
  3. CVE-2025-55346

    Critical · CVSS 9.8EPSS 22.37%No fix published

    Unintended dynamic code execution leads to remote code execution by network attackers

    User-controlled input flows to an unsafe implementation of a dynamic Function constructor, allowing network attackers to run arbitrary unsandboxed JS code in the context of the host, by sending a simple POST request.

    Published Updated
  4. CVE-2024-9148

    Critical · CVSS 9.6EPSS 0.56%Fix available

    Flowise Stored Cross-Site Scripting

    Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

    • Update to 2.1.1
    Published Updated
  5. CVE-2024-8181

    Critical · CVSS 9.8EPSS 45.05%Public exploitNo fix published

    Flowise Authentication Bypass

    An Authentication Bypass vulnerability exists in Flowise version 1.8.2. This could allow a remote, unauthenticated attacker to access API endpoints as an administrator and allow them to access restricted functionality.

    Published Updated
  6. CVE-2024-8182

    High · CVSS 7.5EPSS 13.89%No fix published

    Flowise Denial of Service

    An Unauthenticated Denial of Service (DoS) vulnerability exists in Flowise version 1.8.2 leading to a complete crash of the instance running a vulnerable version due to improper handling of user supplied input to the “/api/v1/get-upload-file” api endpoint.

    Published Updated
  7. CVE-2024-37146

    Medium · CVSS 6.1EPSS 0.4%No fix published

    GHSL-2023-248: Flowise xss in /api/v1/credentials/id

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, a reflected cross-site scripting vulnerability occurs in the `/api/v1/credentials/id` endpoint. If the default configuration is used (unauthenticated), an attacker may be able to craft a specially crafted URL that injects Javascript into the user sessions, allowing the attacker to steal information, create false popups, or even redirect the user to other websites without interaction. If the chatflow ID is not found, its value is reflected in the 404 page, which has type text/html. This allows an attacker to attach arbitrary sc

    Published Updated
  8. CVE-2024-37145

    Medium · CVSS 6.1EPSS 0.46%No fix published

    GHSL-2023-247: Flowise xss in /api/v1/chatflows-streaming/id

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, a reflected cross-site scripting vulnerability occurs in the `/api/v1/chatflows-streaming/id` endpoint. If the default configuration is used (unauthenticated), an attacker may be able to craft a specially crafted URL that injects Javascript into the user sessions, allowing the attacker to steal information, create false popups, or even redirect the user to other websites without interaction. If the chatflow ID is not found, its value is reflected in the 404 page, which has type text/html. This allows an attacker to attach arbi

    Published Updated
  9. CVE-2024-36423

    Medium · CVSS 6.1EPSS 0.4%No fix published

    GHSL-2023-246: Flowise xss in /api/v1/public-chatflows/id

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, a reflected cross-site scripting vulnerability occurs in the `/api/v1/public-chatflows/id` endpoint. If the default configuration is used (unauthenticated), an attacker may be able to craft a specially crafted URL that injects Javascript into the user sessions, allowing the attacker to steal information, create false popups, or even redirect the user to other websites without interaction. If the chatflow ID is not found, its value is reflected in the 404 page, which has type text/html. This allows an attacker to attach arbitra

    Published Updated
  10. CVE-2024-36422

    Medium · CVSS 6.1EPSS 0.41%No fix published

    GHSL-2023-245: Flowise xss in api/v1/chatflows/id

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, a reflected cross-site scripting vulnerability occurs in the `api/v1/chatflows/id` endpoint. If the default configuration is used (unauthenticated), an attacker may be able to craft a specially crafted URL that injects Javascript into the user sessions, allowing the attacker to steal information, create false popups, or even redirect the user to other websites without interaction. If the chatflow ID is not found, its value is reflected in the 404 page, which has type text/html. This allows an attacker to attach arbitrary scrip

    Published Updated
  11. CVE-2024-36421

    High · CVSS 7.5EPSS 8.49%No fix published

    GHSL-2023-234: Flowise Cors Misconfiguration in packages/server/src/index.ts

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, A CORS misconfiguration sets the Access-Control-Allow-Origin header to all, allowing arbitrary origins to connect to the website. In the default configuration (unauthenticated), arbitrary origins may be able to make requests to Flowise, stealing information from the user. This CORS misconfiguration may be chained with the path injection to allow an attacker attackers without access to Flowise to read arbitrary files from the Flowise server. As of time of publication, no known patches are available.

    Published Updated
  12. CVE-2024-36420

    High · CVSS 7.5EPSS 1.78%Public exploitNo fix published

    GHSL-2023-232: Flowise Path Injection at /api/v1/openai-assistants-file

    Flowise is a drag & drop user interface to build a customized large language model flow. In version 1.4.3 of Flowise, the `/api/v1/openai-assistants-file` endpoint in `index.ts` is vulnerable to arbitrary file read due to lack of sanitization of the `fileName` body parameter. No known patches for this issue are available.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →