p PatchFirst

PatchFirst · Latest vulnerabilities

hyperterse vulnerabilities

Vulnerabilities published for hyperterse in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-31841

    Medium · CVSS 6.5EPSS 0.19%Fix available

    Raw exposure of database statements in Hyperterse MCP search tool

    Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

    • Update to 2.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →