p PatchFirst

PatchFirst · Latest vulnerabilities

openclaw 2026.5.26: known vulnerabilities

Known vulnerabilities affecting openclaw 2026.5.26: 4. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-62208

    Medium · CVSS 6.0EPSS 0.36%Fix available

    OpenClaw < 2026.6.5 Authorization Header Forwarding via SSE

    OpenClaw before 2026.6.5 could forward Authorization headers during MCP SSE redirects. When the affected feature is enabled and reachable, a lower-trust caller or configured input path could execute or persist actions beyond the caller's intended authorization. Impact depends on the operator's configuration and whether lower-trust input can reach the affected path.

    • Update to 2026.6.5
    Published Updated
  2. CVE-2026-62197

    Medium · CVSS 6.3EPSS 0.33%Fix available

    OpenClaw < 2026.6.6 Policy Bypass via CDP Discovery

    OpenClaw before 2026.6.6 contains a policy bypass vulnerability in browser CDP discovery that accepts blocked WebSocket URLs. Attackers with lower-trust access can reach network destinations that should have been blocked by OpenClaw policy when the affected feature is enabled.

    • Update to 2026.6.6
    Published Updated
  3. CVE-2026-53838

    Medium · CVSS 6.0EPSS 0.23%Fix available

    OpenClaw < 2026.5.27 - Node Pairing State Mutation via Reconnection

    OpenClaw before 2026.5.27 contains a state mutation vulnerability in node pairing reconnection that allows paired nodes to confuse approval scope decisions. Attackers can exploit reconnection logic to restore or present broader node authority than intended, potentially bypassing approval restrictions.

    • Update to 2026.5.27
    Published Updated
  4. CVE-2026-53819

    High · CVSS 8.7EPSS 0.3%Fix available

    OpenClaw < 2026.5.27 - Arbitrary Homebrew Executable Execution via Workspace .env Override

    OpenClaw before 2026.5.27 contains an arbitrary code execution vulnerability in skill install flows where workspace .env files can override the Homebrew executable selection. Attackers with access to trusted operator workspaces can execute unintended Homebrew-compatible executables during skill setup to compromise the system.

    • Update to 2026.5.27
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →