p PatchFirst

PatchFirst · Latest vulnerabilities

openclaw 2026.5.18: known vulnerabilities

Known vulnerabilities affecting openclaw 2026.5.18: 11. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2026-62208

    Medium · CVSS 6.0EPSS 0.36%Fix available

    OpenClaw < 2026.6.5 Authorization Header Forwarding via SSE

    OpenClaw before 2026.6.5 could forward Authorization headers during MCP SSE redirects. When the affected feature is enabled and reachable, a lower-trust caller or configured input path could execute or persist actions beyond the caller's intended authorization. Impact depends on the operator's configuration and whether lower-trust input can reach the affected path.

    • Update to 2026.6.5
    Published Updated
  2. CVE-2026-62197

    Medium · CVSS 6.3EPSS 0.33%Fix available

    OpenClaw < 2026.6.6 Policy Bypass via CDP Discovery

    OpenClaw before 2026.6.6 contains a policy bypass vulnerability in browser CDP discovery that accepts blocked WebSocket URLs. Attackers with lower-trust access can reach network destinations that should have been blocked by OpenClaw policy when the affected feature is enabled.

    • Update to 2026.6.6
    Published Updated
  3. CVE-2026-53864

    High · CVSS 7.6EPSS 0.25%Fix available

    OpenClaw < 2026.5.26 - Insufficient Environment Variable Sanitization in Node.js Control Variables

    OpenClaw before 2026.5.26 contains an insufficient sanitization vulnerability in the host environment sanitizer that allows Node.js control variables to bypass validation. Attackers with access to workspace .env files, tool environment overrides, or skill environment blocks can pass malicious Node.js control variables to influence child processes or coverage output paths.

    • Update to 2026.5.26
    Published Updated
  4. CVE-2026-53859

    Medium · CVSS 6.0EPSS 0.21%Fix available

    OpenClaw < 2026.5.26 - Hostname Validation Bypass via Trailing-Dot Inconsistency

    OpenClaw before 2026.5.26 contains a hostname validation vulnerability allowing attackers to bypass blocklist comparisons using trailing-dot notation in model or workspace-derived URLs. Attackers can exploit inconsistent hostname checks to reach destinations that operators intended to block through hostname policies.

    • Update to 2026.5.26
    Published Updated
  5. CVE-2026-53848

    Low · CVSS 2.3EPSS 0.18%Fix available

    OpenClaw < 2026.5.26 - Exec Allowlist Bypass via Transparent Command Wrappers

    OpenClaw before 2026.5.26 contains an exec allowlist bypass vulnerability allowing authenticated operators to execute wrapper-level side effects outside allowlisted command intent. Attackers can craft command requests that bypass allowlist validation by leveraging transparent command wrappers to perform unintended operations.

    • Update to 2026.5.26
    Published Updated
  6. CVE-2026-53843

    High · CVSS 8.7EPSS 0.27%Fix available

    OpenClaw < 2026.5.26 - Node Token Revocation Bypass via Pairing-Scoped Device Session

    OpenClaw before 2026.5.26 contains an authorization bypass vulnerability where a surviving pairing-scoped device session can re-establish node token authority after revocation. Attackers with a paired device can regain WebSocket node-level access without renewed approval, weakening revocation controls and maintaining unauthorized access longer than intended.

    • Update to 2026.5.26
    Published Updated
  7. CVE-2026-53838

    Medium · CVSS 6.0EPSS 0.23%Fix available

    OpenClaw < 2026.5.27 - Node Pairing State Mutation via Reconnection

    OpenClaw before 2026.5.27 contains a state mutation vulnerability in node pairing reconnection that allows paired nodes to confuse approval scope decisions. Attackers can exploit reconnection logic to restore or present broader node authority than intended, potentially bypassing approval restrictions.

    • Update to 2026.5.27
    Published Updated
  8. CVE-2026-53819

    High · CVSS 8.7EPSS 0.3%Fix available

    OpenClaw < 2026.5.27 - Arbitrary Homebrew Executable Execution via Workspace .env Override

    OpenClaw before 2026.5.27 contains an arbitrary code execution vulnerability in skill install flows where workspace .env files can override the Homebrew executable selection. Attackers with access to trusted operator workspaces can execute unintended Homebrew-compatible executables during skill setup to compromise the system.

    • Update to 2026.5.27
    Published Updated
  9. CVE-2026-53817

    High · CVSS 8.7EPSS 0.31%Fix available

    OpenClaw < 2026.5.22 - Control UI Locality Spoofing in Device Pairing

    OpenClaw before 2026.5.22 contains a locality validation vulnerability in Control UI pairing that allows attackers with network access to spoof locality information and obtain durable admin-capable device tokens. Attackers can exploit insufficient locality-derived trust validation to convert temporary shared access into persistent administrative credentials that survive token rotation.

    • Update to 2026.5.22
    Published Updated
  10. CVE-2026-53815

    High · CVSS 7.1EPSS 0.21%Fix available

    OpenClaw < 2026.5.19 - Channel Allowlist Bypass in Message Read Actions

    OpenClaw before 2026.5.19 contains an authorization bypass vulnerability in message read actions that skips channel allowlist checks. Lower-trust callers can request messages from channels not intended for them by exploiting insufficient validation in the affected feature, potentially exposing sensitive channel messages.

    • Update to 2026.5.19
    Published Updated
  11. CVE-2026-53814

    High · CVSS 8.7EPSS 0.28%Fix available

    OpenClaw < 2026.5.20 - Privilege Escalation via Hook-Triggered CLI MCP Tool Authority

    OpenClaw before 2026.5.20 contains a privilege escalation vulnerability where hook-triggered agent runs incorrectly receive owner-scoped MCP loopback authority instead of hook-appropriate scope. Attackers with a valid hook token can exploit the /hooks/agent endpoint to cause spawned CLI runtimes to access or invoke owner-only MCP tools, potentially executing privileged actions like persistent cron state modifications.

    • Update to 2026.5.20
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →