p PatchFirst

PatchFirst · Latest vulnerabilities

parse-server 9.8.0-alpha.7: known vulnerabilities

Known vulnerabilities affecting parse-server 9.8.0-alpha.7: 8. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-57481

    Low · CVSS 2.3EPSS 0.53%Fix available

    Parse Server: LiveQuery discloses object data to a subscriber across an ACL read-access change

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.13 and 8.6.83, a LiveQuery subscriber could receive object field values they were not authorized to read when a single save changed both an object field and the subscriber's ACL read access, because leave and enter events included the wrong object state. This issue is fixed in versions 9.9.1-alpha.13 and 8.6.83.

    • Update to 9.9.1-alpha.13
    Published Updated
  2. CVE-2026-57480

    High · CVSS 8.7EPSS 0.59%Fix available

    Parse Server: Denial of service via exponential-time processing of deeply nested query operators

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

    • Update to 9.9.1-alpha.12
    Published Updated
  3. CVE-2026-55778

    Low · CVSS 2.1EPSS 0.55%Fix available

    Parse Server: Stored XSS via non-standard file extension bypassing file upload extension blocklist

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.11 and 8.6.81, the default fileUpload.fileExtensions blocklist could be bypassed by uploading a file with a non-standard or compound extension and dangerous content type, allowing storage adapters such as S3 and GCS to serve attacker-supplied active content and enable stored cross-site scripting. This issue is fixed in versions 9.9.1-alpha.11 and 8.6.81.

    • Update to 9.9.1-alpha.11
    Published Updated
  4. CVE-2026-53726

    Medium · CVSS 6.9EPSS 0.28%Fix available

    Parse Server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.80 and 9.9.1-alpha.6, a relation query using the $relatedTo operator could read the membership of a Relation field even when that field was hidden from the requesting client by protectedFields, and even when the object owning the relation was not readable by the client under its ACL or class-level permissions. The request requires only the public API credentials that Parse clients normally carry — no user session, master key, or Cloud Code is needed. As a result, an unauthenticated client who knows or obtains the ownin

    • Update to 9.9.1-alpha.6
    Published Updated
  5. CVE-2026-53724

    Low · CVSS 2.1EPSS 0.28%Fix available

    Parse Server: Stored XSS via trailing-dot filename bypassing file upload extension blocklist

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.79 and 9.9.1-alpha.4, the default file upload extension blocklist can be bypassed by appending a trailing dot to a filename whose extension would otherwise be blocked (e.g. poc.svg.). The trailing dot causes the extension parser to extract an empty string, which short-circuits the blocklist check, and the attacker-controlled Content-Type is forwarded to the storage adapter unchanged. Storage adapters that persist and serve the provided Content-Type (such as S3 or GCS) then serve the file with an active type such as ima

    • Update to 9.9.1-alpha.4
    Published Updated
  6. CVE-2026-47138

    High · CVSS 8.7EPSS 0.58%Fix available

    Parse Server: Pre-authentication denial of service via client version header regex backtracking

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can satura

    • Update to 9.9.1-alpha.1
    Published Updated
  7. CVE-2026-47248

    Medium · CVSS 6.9EPSS 0.29%Fix available

    Parse Server: GraphQL "Did you mean" validation suggestions disclose schema to unauthenticated callers

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.78 and 9.9.1-alpha.2, Parse Server's GraphQL endpoint discloses schema metadata to unauthenticated callers through Did you mean ...? suggestions embedded in GraphQL validation-error messages. An unauthenticated caller who knows only the public application id can iteratively send malformed queries to reconstruct class names, field names, argument names, mutation names, and input-object fields. This issue has been patched in versions 8.6.78 and 9.9.1-alpha.2.

    • Update to 9.9.1-alpha.2
    Published Updated
  8. CVE-2026-43930

    Low · CVSS 2.1EPSS 0.24%Fix available

    Parse Server: MFA SMS one-time password accepted twice under concurrent login

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.76 and 9.9.0-alpha.2, a race condition in the MFA SMS one-time password (OTP) login path allows two concurrent /login requests carrying the same OTP to both succeed and both receive valid session tokens, breaking the single-use property of the OTP. The vulnerability requires the attacker to already possess the victim's password and intercept the active SMS OTP (e.g. via SIM swap, network mirror, or phishing relay) and to race the legitimate login request, so the practical attack surface is narrow. This vulnerability is fixed in

    • Update to 9.9.0-alpha.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →