p PatchFirst

PatchFirst · Latest vulnerabilities

parse-server 9.9.1-alpha.11: known vulnerabilities

Known vulnerabilities affecting parse-server 9.9.1-alpha.11: 2. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-57481

    Low · CVSS 2.3EPSS 0.53%Fix available

    Parse Server: LiveQuery discloses object data to a subscriber across an ACL read-access change

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.13 and 8.6.83, a LiveQuery subscriber could receive object field values they were not authorized to read when a single save changed both an object field and the subscriber's ACL read access, because leave and enter events included the wrong object state. This issue is fixed in versions 9.9.1-alpha.13 and 8.6.83.

    • Update to 9.9.1-alpha.13
    Published Updated
  2. CVE-2026-57480

    High · CVSS 8.7EPSS 0.59%Fix available

    Parse Server: Denial of service via exponential-time processing of deeply nested query operators

    Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

    • Update to 9.9.1-alpha.12
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →