p PatchFirst

PatchFirst · Latest vulnerabilities

magento/community-edition vulnerabilities · Page 13

Vulnerabilities published for magento/community-edition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 360

  1. CVE-2019-8154

    High · CVSS 8.8EPSS 1.89%Fix available

    CVE-2019-8154

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to modify product catalogs can trigger PHP file inclusion through a crafted XML file that specifies product design update.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  2. CVE-2019-8153

    Medium · CVSS 6.1EPSS 1.48%Fix available

    CVE-2019-8153

    A mitigation bypass to prevent cross-site scripting (XSS) exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Successful exploitation of this vulnerability would result in an attacker being able to bypass the `escapeURL()` function and execute a malicious XSS payload.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  3. CVE-2019-8152

    Medium · CVSS 4.8EPSS 0.59%Fix available

    CVE-2019-8152

    A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  4. CVE-2019-8151

    High · CVSS 7.2EPSS 1.71%Fix available

    CVE-2019-8151

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to manipulate shippment settings can execute arbitrary code through server-side request forgery due to unsafe handling of a carrier gateway.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  5. CVE-2019-8149

    Critical · CVSS 9.8EPSS 2.14%Fix available

    CVE-2019-8149

    Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can append arbitrary session id that will not be invalidated by subsequent authentication.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  6. CVE-2019-8143

    Medium · CVSS 6.5EPSS 0.9%Fix available

    CVE-2019-8143

    A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to email templates can send malicious SQL queries and obtain access to sensitive information stored in the database.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  7. CVE-2019-8142

    Medium · CVSS 5.4EPSS 0.56%Fix available

    CVE-2019-8142

    A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code via title of an order when configuring sales payment methods for a store.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  8. CVE-2019-8141

    High · CVSS 7.2EPSS 2.38%Fix available

    CVE-2019-8141

    A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with administrative privileges (system level import) can execute arbitrary code through a Phar deserialization vulnerability in the import functionality.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  9. CVE-2019-8140

    Medium · CVSS 4.9EPSS 0.76%Fix available

    CVE-2019-8140

    An unrestricted file upload vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can manipulate the Synchronization feature in the Media File Storage of the database to transform uploaded JPEG file into a PHP file.

    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  10. CVE-2019-8138

    Medium · CVSS 5.4EPSS 0.56%Fix available

    CVE-2019-8138

    A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can execute arbitrary JavaScript code by providing arbitrary API endpoint that will not be chcecked by sale pickup event.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  11. CVE-2019-8135

    Critical · CVSS 9.8EPSS 2.46%Fix available

    CVE-2019-8135

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Dependency injection through Symphony framework allows service identifiers to be derived from user controlled data, which can lead to remote code execution.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →