p PatchFirst

PatchFirst · Latest vulnerabilities

magento/community-edition vulnerabilities · Page 15

Vulnerabilities published for magento/community-edition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 360

  1. CVE-2019-8110

    High · CVSS 8.8EPSS 1.92%Fix available

    CVE-2019-8110

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage email templates hierarchy to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  2. CVE-2019-8108

    Medium · CVSS 6.5EPSS 1.17%Fix available

    CVE-2019-8108

    Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can manipulate session validation setting for a storefront that leads to insecure authentication and session management.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  3. CVE-2019-7853

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7853

    A stored cross-site scripting vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to the tax notifications configuration in the Magento admin panel.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  4. CVE-2019-7951

    High · CVSS 7.5EPSS 1.19%Fix available

    CVE-2019-7951

    An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly enforce parameters related to access control. This could be abused to leak customer information via crafted SOAP requests.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  5. CVE-2019-7950

    High · CVSS 7.5EPSS 2.16%Fix available

    CVE-2019-7950

    An access control bypass vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An unauthenticated user can bypass access controls via REST API calls to assign themselves to an arbitrary company, thereby gaining read access to potentially confidental information.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  6. CVE-2019-7947

    Medium · CVSS 6.5EPSS 0.44%Fix available

    CVE-2019-7947

    A cross-site request forgery vulnerability exists in the GiftCardAccount removal feature for Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  7. CVE-2019-7945

    Medium · CVSS 5.4EPSS 0.57%Fix available

    CVE-2019-7945

    A stored cross-cite scripting vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to modify currency symbols can inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  8. CVE-2019-7944

    Medium · CVSS 5.4EPSS 0.57%Fix available

    CVE-2019-7944

    A stored cross-site scripting vulnerability exists in the product comments field of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to the Return Product comments field can inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  9. CVE-2019-7942

    High · CVSS 7.2EPSS 1.92%Fix available

    CVE-2019-7942

    A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to create or edit a product can execute arbitrary code via malicious XML layout updates.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  10. CVE-2019-7939

    Medium · CVSS 6.1EPSS 1.04%Fix available

    CVE-2019-7939

    A reflected cross-site scripting vulnerability exists on the customer cart checkout page of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by sending a victim a crafted URL that results in malicious javascript execution in the victim's browser.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  11. CVE-2019-7938

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7938

    A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify catalog price rules to inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  12. CVE-2019-7937

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7937

    A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to store product attributes to inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  13. CVE-2019-7936

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7936

    A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify content block titles to inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  14. CVE-2019-7935

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7935

    A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify content page titles to inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated
  15. CVE-2019-7934

    Medium · CVSS 4.8EPSS 0.56%Fix available

    CVE-2019-7934

    A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to edit newsletter templates to inject malicious javascript.

    • Update to 2.1.18
    • Update to 2.2.9
    • Update to 2.3.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →