p PatchFirst

PatchFirst · Latest vulnerabilities

magento/community-edition vulnerabilities · Page 14

Vulnerabilities published for magento/community-edition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 360

  1. CVE-2019-8133

    Medium · CVSS 6.5EPSS 0.99%Fix available

    CVE-2019-8133

    A security bypass vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with privileges to generate sitemaps can bypass configuration that restricts directory access. The bypass allows overwrite of a subset of configuration files which can lead to denial of service.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  2. CVE-2019-8130

    High · CVSS 8.8EPSS 1%Fix available

    CVE-2019-8130

    A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with store manipulation privileges can execute arbitrary SQL queries by getting access to the database connection through group instance in email templates.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  3. CVE-2019-8127

    High · CVSS 8.8EPSS 1.26%Fix available

    CVE-2019-8127

    A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to an account with Newsletter Template editing permission could exfiltrate the Admin login data, and reset their password, effectively performing a privilege escalation.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  4. CVE-2019-8126

    Medium · CVSS 4.9EPSS 0.88%Fix available

    CVE-2019-8126

    An XML entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can craft document type definition for an XML representing XML layout. The crafted document type definition and XML layout allow processing of external entities which can lead to information disclosure.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  5. CVE-2019-8124

    Medium · CVSS 4.9EPSS 0.96%Fix available

    CVE-2019-8124

    An insufficient logging and monitoring vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Failure to track admin actions related to design configuration could lead to repudiation attacks.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  6. CVE-2019-8123

    Medium · CVSS 5.3EPSS 0.81%Fix available

    CVE-2019-8123

    An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  7. CVE-2019-8122

    High · CVSS 8.8EPSS 1.92%Fix available

    CVE-2019-8122

    A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with privileges to create products can craft custom layout update and use import product functionality to enable remote code execution.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  8. CVE-2019-8120

    Medium · CVSS 5.4EPSS 0.56%Fix available

    CVE-2019-8120

    A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  9. CVE-2019-8119

    High · CVSS 7.2EPSS 1.85%Fix available

    CVE-2019-8119

    A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated admin user with import product privileges can delete files through bulk product import and inject code into XSLT file. The combination of these manipulations can lead to remote code execution.

    • Update to 2.1.19
    • Update to 2.2.10
    • Update to 2.3.3
    Published Updated
  10. CVE-2019-8114

    High · CVSS 7.2EPSS 1.85%Fix available

    CVE-2019-8114

    A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload.

    • Update to 1.9.4.3
    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  11. CVE-2019-8112

    High · CVSS 7.5EPSS 0.56%Fix available

    CVE-2019-8112

    A security bypass vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can bypass the email confirmation mechanism via GET request that captures relevant account data obtained from the POST response related to new user creation.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  12. CVE-2019-8111

    High · CVSS 8.8EPSS 1.92%Fix available

    CVE-2019-8111

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage plugin functionality related to email templates to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →