p PatchFirst

PatchFirst · Latest vulnerabilities

microweber/microweber 2.0.4: known vulnerabilities

Known vulnerabilities affecting microweber/microweber 2.0.4: 15. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 15

  1. CVE-2026-12198

    Medium · CVSS 6.9EPSS 0.53%No fix published

    Microweber API Endpoint thumbnail_img userfiles_path path traversal

    A weakness has been identified in Microweber up to 2.0.20. This affects the function userfiles_path of the file /api_nosession/thumbnail_img of the component API Endpoint. Executing a manipulation of the argument cache_path_relative can lead to path traversal. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

    Published Updated
  2. CVE-2025-70792

    Medium · CVSS 6.1EPSS 0.32%Fix available

    CVE-2025-70792

    Cross Site Scripting vulnerability in the "/admin/category/create" endpoint of Microweber 2.0.19. An attacker can manipulate the "rel_id" parameter in a crafted URL and lure a user with admin privileges into visiting it, achieving JavaScript code execution in the victim's browser. The issue was reported to the developers and fixed in version 2.0.20.

    • Update to 2.0.20
    Published Updated
  3. CVE-2025-70791

    Medium · CVSS 6.1EPSS 0.31%Fix available

    CVE-2025-70791

    Cross Site Scripting vulnerability in the "/admin/order/abandoned" endpoint of Microweber 2.0.19. An attacker can manipulate the "orderDirection" parameter in a crafted URL and lure a user with admin privileges into visiting it, achieving JavaScript code execution in the victim's browser. The issue was reported to the developers and fixed in version 2.0.20.

    • Update to 2.0.20
    Published Updated
  4. CVE-2025-2214

    Medium · CVSS 5.1EPSS 0.52%No fix published

    Microweber Settings index.php cross site scripting

    A vulnerability was found in Microweber 2.0.19. It has been rated as problematic. This issue affects some unknown processing of the file userfiles/modules/settings/group/website_group/index.php of the component Settings Handler. The manipulation of the argument group leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →