p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 17

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2015-2273

    Not ratedEPSS 1.45%Fix available

    CVE-2015-2273

    Cross-site scripting (XSS) vulnerability in mod/quiz/report/statistics/statistics_question_table.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the student role for a crafted quiz response.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  2. CVE-2015-2271

    Not ratedEPSS 1.7%Fix available

    CVE-2015-2271

    tag/user.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/tag:flag capability before proceeding with a flaginappropriate action, which allows remote authenticated users to bypass intended access restrictions via the "Flag as inappropriate" feature.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  3. CVE-2015-2270

    Not ratedEPSS 1.86%Fix available

    CVE-2015-2270

    lib/moodlelib.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4, when the theme uses the blocks-regions feature, establishes the course state at an incorrect point in the login-validation process, which allows remote attackers to obtain sensitive course information via unspecified vectors.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  4. CVE-2015-2269

    Not ratedEPSS 3.26%Public exploitFix available

    CVE-2015-2269

    Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  5. CVE-2015-2268

    Not ratedEPSS 2.22%Fix available

    CVE-2015-2268

    filter/urltolink/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  6. CVE-2015-2267

    Not ratedEPSS 1.61%Fix available

    CVE-2015-2267

    mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass intended access restrictions and extract archives to arbitrary directories via a crafted dataroot value.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  7. CVE-2015-2266

    Not ratedEPSS 1.67%Fix available

    CVE-2015-2266

    message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.

    • Update to 2.6.9
    • Update to 2.7.6
    • Update to 2.8.4
    Published Updated
  8. CVE-2015-1493

    Not ratedEPSS 2.62%Fix available

    CVE-2015-1493

    Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

    • Update to 2.6.8
    • Update to 2.7.5
    • Update to 2.8.3
    Published Updated
  9. CVE-2015-0218

    Not ratedEPSS 1.01%Fix available

    CVE-2015-0218

    Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  10. CVE-2015-0217

    Not ratedEPSS 2.22%Fix available

    CVE-2015-0217

    filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  11. CVE-2015-0214

    Not ratedEPSS 1.7%Fix available

    CVE-2015-0214

    message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  12. CVE-2015-0213

    Not ratedEPSS 1.01%Fix available

    CVE-2015-0213

    Multiple cross-site request forgery (CSRF) vulnerabilities in (1) editcategories.html and (2) editcategories.php in the Glossary module in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allow remote attackers to hijack the authentication of unspecified victims.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  13. CVE-2015-0212

    Not ratedEPSS 1.45%Fix available

    CVE-2015-0212

    Cross-site scripting (XSS) vulnerability in course/pending.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted course summary.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  14. CVE-2015-0211

    Not ratedEPSS 1.67%Fix available

    CVE-2015-0211

    mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 does not consider the moodle/course:manageactivities and mod/lti:addinstance capabilities before proceeding with registered-tool list searches, which allows remote authenticated users to obtain sensitive information via requests to the LTI Ajax service.

    • Update to 2.6.7
    • Update to 2.7.4
    • Update to 2.8.2
    Published Updated
  15. CVE-2014-9060

    Not ratedEPSS 2.12%Fix available

    CVE-2014-9060

    The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

    • Update to 2.5.9
    • Update to 2.6.6
    • Update to 2.7.3
    Published Updated
  16. CVE-2014-9059

    Not ratedEPSS 1.83%Fix available

    CVE-2014-9059

    lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.

    • Update to 2.5.9
    • Update to 2.6.6
    • Update to 2.7.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →