p PatchFirst

PatchFirst · Latest vulnerabilities

phpmyfaq/phpmyfaq 4.1.5: known vulnerabilities

Known vulnerabilities affecting phpmyfaq/phpmyfaq 4.1.5: 3. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-56738

    High · CVSS 8.5EPSS 0.26%Public exploitFix available

    phpMyFAQ has SQL Injection in `StopWords::add()` — Unescaped Stop Word Insertion

    phpMyFAQ is an open source FAQ web application. The `StopWords::add()` method inversions prior to 4.1.6 builds a SQL `INSERT` statement using `sprintf()` and inserts the user-supplied stop word value directly into the query string without calling the application's database escaping function on it. A sibling method, `StopWords::update()`, which modifies an existing stop word, correctly escapes the same kind of input. The omission is isolated to the `add()` (insert) code path. An authenticated administrator who can reach the stop-word management feature can submit a crafted value as the "word" parameter that breaks out of the SQL string literal

    • Update to 4.1.6
    Published Updated
  2. CVE-2026-56737

    High · CVSS 8.1EPSS 0.53%Fix available

    phpMyFAQ's two-factor authentication login bypasses the password factor

    phpMyFAQ is an open source FAQ web application. Versions 3.2.0 through 4.1.5 contain an authentication bypass in its public two-factor authentication verification flow: an unauthenticated attacker can submit an account’s numeric user ID and a valid or brute-forced six-digit TOTP code without first authenticating with the account password, allowing takeover of any 2FA-enabled account, including administrator accounts. Version 4.1.6 is patched by binding TOTP verification to a session established after successful password authentication and limiting failed TOTP attempts. No official workaround is documented; affected installations should upgrad

    • Update to 4.1.6
    Published Updated
  3. CVE-2026-56736

    High · CVSS 8.2EPSS 0.24%Fix available

    phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission

    phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2

    • Update to 4.2.0-alpha
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →