p PatchFirst

PatchFirst · Latest vulnerabilities

phpmyfaq/phpmyfaq 4.1.7: known vulnerabilities

Known vulnerability affecting phpmyfaq/phpmyfaq 4.1.7: 1. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-56736

    High · CVSS 8.2EPSS 0.24%Fix available

    phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission

    phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2

    • Update to 4.2.0-alpha
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →