p PatchFirst

PatchFirst · Latest vulnerabilities

pocketmine/pocketmine-mp 5.40.0: known vulnerabilities

Known vulnerabilities affecting pocketmine/pocketmine-mp 5.40.0: 2. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-86201

    High · CVSS 8.7EPSS 0.61%Fix available

    PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData

    PocketMine-MP before 5.41.1 contains a denial of service vulnerability in LoginPacket processing where large or complex structures in unknown clientData JWT properties cause excessive logging without sanitization. Attackers can send crafted LoginPackets with deeply nested or massive object structures to trigger out-of-memory conditions and crash the server.

    • Update to 5.41.1
    Published Updated
  2. CVE-2026-86200

    Medium · CVSS 6.9EPSS 0.64%Fix available

    PocketMine-MP before 5.42.1 LogDoS via LoginPacket clientData JWT

    PocketMine-MP versions before 5.42.1 contain a denial of service vulnerability in the LoginPacket handler that allows remote attackers to flood warning messages by injecting numerous junk properties into the clientData JWT. Attackers can craft malicious login packets with excessive unknown properties to waste server CPU time and degrade performance.

    • Update to 5.42.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →