p PatchFirst

PatchFirst · Latest vulnerabilities

prestashop/prestashop 8.2.4: known vulnerabilities

Known vulnerabilities affecting prestashop/prestashop 8.2.4: 3. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-44212

    Critical · CVSS 9.3EPSS 0.43%Fix available

    PrestaShop: Stored XSS executable in customer service view

    PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.

    • Update to 8.2.6
    Published Updated
  2. CVE-2026-33673

    High · CVSS 7.7EPSS 0.27%Fix available

    PrestaShop has multiple stored XSS vulnerabilities via unprotected Template variables

    PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 are vulnerable to stored Cross-Site Scripting (stored XSS) vulnerabilities in the BO. An attacker who can inject data into the database, via limited back-office access or a previously existing vulnerability, can exploit unprotected variables in back-office templates. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.

    • Update to 8.2.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →