p PatchFirst

PatchFirst · Latest vulnerabilities

shopware/shopware 5.7.9: known vulnerabilities

Known vulnerabilities affecting shopware/shopware 5.7.9: 7. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2023-34099

    Medium · CVSS 5.3EPSS 0.65%Fix available

    Improper mail validation in Shopware

    Shopware is an open source e-commerce software. The mail validation in the registration process had some flaws, so it was possible to construct different mail addresses, that in the end result in the same address, which is shared by multiple accounts. This issue has been addressed in version 5.7.18 and users are advised to update. There are no known workarounds for this vulnerability.

    • Update to 5.7.18
    Published Updated
  2. CVE-2023-34098

    Medium · CVSS 5.3EPSS 0.61%Fix available

    Dependency configuration exposed in Shopware

    Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.

    • Update to 5.7.18
    Published Updated
  3. CVE-2022-36102

    Medium · CVSS 6.3EPSS 0.8%Fix available

    Acess control list bypassed via crafted specific URLs

    Shopware is an open source e-commerce software. In affected versions if backend admin controllers are called with a certain notation, the ACL could be bypassed. Users could execute actions, which they are normally not able to do. Users are advised to update to the current version (5.7.15). Users can get the update via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

    • Update to 5.7.15
    Published Updated
  4. CVE-2022-36101

    Medium · CVSS 5.4EPSS 0.7%Fix available

    Sensitive data in backend customer module

    Shopware is an open source e-commerce software. In affected versions the request for the customer detail view in the backend administration contained sensitive data like the hashed password and the session ID. These fields are now explicitly unset in version 5.7.15. Users are advised to update and may get the update either via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

    • Update to 5.7.15
    Published Updated
  5. CVE-2022-31148

    Medium · CVSS 5.4EPSS 0.69%Fix available

    Persistent cross site scripting in customer module in Shopware

    Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

    • Update to 5.7.14
    Published Updated
  6. CVE-2022-31057

    Medium · CVSS 6.5EPSS 0.7%Fix available

    Authenticated Stored XSS in Shopware Administration

    Shopware is an open source e-commerce software made in Germany. Versions of Shopware 5 prior to version 5.7.12 are subject to an authenticated Stored XSS in Administration. Users are advised to upgrade. There are no known workarounds for this issue.

    • Update to 5.7.12
    Published Updated
  7. GHSA-3pcr-4982-548m

    Not ratedFix available

    Exposure of .env if project root is configured as web root in shopware/production

    ### Impact The .env and other sensitive files can be leaked if the project root and not `/public` is configured as the web root. ### Patches We recommend to update to the current version 6.3.5.3. You can get the update to 6.3.5.3 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 ### Workarounds You should always use `/public` as the web root. For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index

    • Update to 6.3.5.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →