p PatchFirst

PatchFirst · Latest vulnerabilities

litellm 1.92.0: known vulnerabilities

Known vulnerabilities affecting litellm 1.92.0: 3. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. GHSA-g5ff-637f-6q2m

    High · CVSS 8.1Fix available

    LiteLLM: internal_user_viewer arbitrary local file read via `vertex_ai_credentials`

    ## Summary An authenticated LiteLLM proxy user could read arbitrary local files from the proxy runtime by sending a crafted `vertex_ai_credentials` value to `/utils/transform_request`. The request-body safety blocklist rejected `vertex_credentials` but missed its alias `vertex_ai_credentials`, which let the value reach the Vertex AI credential loader and trigger a file read that is sent to an attacker-controlled URL. ## Impact A low-privilege authenticated user (only `internal_user_viewer`, obtainable through SSO login on many deployments) could read any file readable by the LiteLLM process. Reading files such as `/proc/self/environ` can d

    • Update to 1.95.0
    Published Updated
  2. CVE-2026-114612

    Critical · CVSS 9.9EPSS 0.32%Public exploitFix available

    LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key

    LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_L

    • Update to 1.100.4
    Published Updated
  3. CVE-2026-84377

    Medium · CVSS 6.5EPSS 0.54%Fix available

    LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters

    LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalen

    • Update to 1.92.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →