p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 108

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2025-4416

    High · CVSS 7.5EPSS 0.42%Fix available

    Events Log Track - Moderately critical - Denial of Service - SA-CONTRIB-2025-059

    Allocation of Resources Without Limits or Throttling vulnerability in Drupal Events Log Track allows Excessive Allocation.This issue affects Events Log Track: from 0.0.0 before 3.1.11, from 4.0.0 before 4.0.2.

    • Update to 3.1.11
    • Update to 4.0.2
    Published Updated
  2. CVE-2025-4415

    Medium · CVSS 4.8EPSS 0.23%Fix available

    Piwik PRO - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-058

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Piwik PRO allows Cross-Site Scripting (XSS).This issue affects Piwik PRO: from 0.0.0 before 1.3.2.

    • Update to 1.3.2
    Published Updated
  3. CVE-2025-47941

    High · CVSS 7.2EPSS 0.47%Fix available

    TYPO3 Has Broken Authentication in Backend MFA

    TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, the multifactor authentication (MFA) dialog presented during backend login can be bypassed due to insufficient enforcement of access restrictions on all backend routes. Successful exploitation requires valid backend user credentials, as MFA can only be bypassed after successful authentication. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to fix the problem.

    • Update to 12.4.31
    • Update to 13.4.12
    Published Updated
  4. CVE-2025-47940

    High · CVSS 7.2EPSS 0.46%Fix available

    TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer

    TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

    • Update to 10.4.50
    • Update to 11.5.44
    • Update to 12.4.31
    • Update to 13.4.12
    Published Updated
  5. CVE-2025-47939

    Medium · CVSS 5.4EPSS 0.18%Fix available

    TYPO3 CMS Vulnerable to Unrestricted File Upload in File Abstraction Layer

    TYPO3 is an open source, PHP based web content management system. By design, the file management module in TYPO3’s backend user interface has historically allowed the upload of any file type, with the exception of those that are directly executable in a web server context. This lack of restriction means it is possible to upload files that may be considered potentially harmful, such as executable binaries (e.g., `.exe` files), or files with inconsistent file extensions and MIME types (for example, a file incorrectly named with a `.png` extension but actually carrying the MIME type `application/zip`) starting in version 9.0.0 and prior to versi

    • Update to 10.4.50
    • Update to 11.5.44
    • Update to 12.4.31
    • Update to 13.4.12
    • Update to 9.5.51
    Published Updated
  6. CVE-2025-47938

    Low · CVSS 3.8EPSS 0.27%Fix available

    TYPO3 Vulnerable to Unverified Password Change for Backend Users

    TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, the backend user management interface allows password changes without requiring the current password. When an administrator updates their own account or modifies other user accounts via the admin interface, the current password is not requested for verification. This behavior may lower the protection against unauthorized access in scenarios where an admin session is hijacked or left unattended, as it enables password changes without additional authentication. U

    • Update to 10.4.50
    • Update to 11.5.44
    • Update to 12.4.31
    • Update to 13.4.12
    • Update to 9.5.51
    Published Updated
  7. CVE-2025-47937

    Low · CVSS 3.7EPSS 0.3%Fix available

    TYPO3 Vulnerable to Information Disclosure via DBAL Restriction Handling

    TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, when performing a database query involving multiple tables through the database abstraction layer (DBAL), frontend user permissions are only applied via `FrontendGroupRestriction` to the first table. As a result, data from additional tables included in the same query may be unintentionally exposed to unauthorized users. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

    • Update to 10.4.50
    • Update to 11.5.44
    • Update to 12.4.31
    • Update to 13.4.12
    • Update to 9.5.51
    Published Updated
  8. CVE-2025-47936

    Low · CVSS 3.3EPSS 0.27%Fix available

    TYPO3 Vulnerable to Server Side Request Forgery via Webhooks

    TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, Webhooks are inherently vulnerable to Cross-Site Request Forgery (CSRF), which can be exploited by adversaries to target internal resources (e.g., localhost or other services on the local network). While this is not a vulnerability in TYPO3 itself, it may enable attackers to blindly access systems that would otherwise be inaccessible. An administrator-level backend user account is required to exploit this vulnerability. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to

    • Update to 12.4.31
    • Update to 13.4.12
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →