p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 179

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-47129

    High · CVSS 8.4EPSS 1.12%Fix available

    Statamic CMS remote code execution via front-end form uploads

    Statmic is a core Laravel content management system Composer package. Prior to versions 3.4.13 and 4.33.0, on front-end forms with an asset upload field, PHP files crafted to look like images may be uploaded. This only affects forms using the "Forms" feature and not just _any_ arbitrary form. This does not affect the control panel. This issue has been patched in 3.4.13 and 4.33.0.

    • Update to 3.4.13
    • Update to 4.33.0
    Published Updated
  2. CVE-2023-46735

    Medium · CVSS 6.1EPSS 0.57%Fix available

    Symfony potential Cross-site Scripting in WebhookController

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in version 6.0.0 and prior to version 6.3.8, the error message in `WebhookController` returns unescaped user-submitted input. As of version 6.3.8, `WebhookController` now doesn't return any user-submitted input in its response.

    • Update to 6.3.8
    Published Updated
  3. CVE-2023-46734

    Medium · CVSS 6.1EPSS 0.69%Fix available

    Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

    • Update to 4.3.8+dfsg-1ubuntu1+esm2
    • Update to 4.4.51
    • Update to 5.4.23+dfsg-1+deb12u1
    • Update to 5.4.31
    • Update to 5.4.31+dfsg-1
    • Update to 5.4.4+dfsg-1ubuntu8+esm1
    • Update to 6.3.8
    Published Updated
  4. CVE-2023-46733

    Medium · CVSS 6.5EPSS 0.69%Fix available

    Symfony possible session fixation vulnerability

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 5.4.21 and 6.2.7 and prior to versions 5.4.31 and 6.3.8, `SessionStrategyListener` does not migrate the session after every successful login. It does so only in case the logged in user changes by means of checking the user identifier. In some use cases, the user identifier doesn't change between the verification phase and the successful login, while the token itself changes from one type (partially-authenticated) to another (fully-authenticated). When this happens, the session id should be regenerated to prevent possible sess

    • Update to 5.4.23+dfsg-1+deb12u1
    • Update to 5.4.31
    • Update to 5.4.31+dfsg-1
    • Update to 6.3.8
    Published Updated
  5. CVE-2023-5551

    Low · CVSS 3.3EPSS 0.29%Fix available

    Moodle: forum summary report shows students from other groups when in separate groups mode

    Separate Groups mode restrictions were not honoured in the forum summary report, which would display users from other groups.

    • Update to 3.11.17
    • Update to 3.9.24
    • Update to 4.0.11
    • Update to 4.1.6
    • Update to 4.2.3
    • Update to 4.3.0-rc2
    Published Updated
  6. CVE-2023-5550

    Medium · CVSS 6.5EPSS 1.62%Fix available

    Moodle: rce due to lfi risk in some misconfigured shared hosting environments

    In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.

    • Update to 3.11.17
    • Update to 3.9.24
    • Update to 4.0.11
    • Update to 4.1.6
    • Update to 4.2.3
    • Update to 4.3.0-rc2
    Published Updated
  7. CVE-2023-47110

    Critical · CVSS 9.1EPSS 0.42%Fix available

    Any value can be changed in the configuration table by an employee having access to block reassurance module

    blockreassurance adds an information block aimed at offering helpful information to reassure customers that their store is trustworthy. An ajax function in module blockreassurance allows modifying any value in the configuration table. This vulnerability has been patched in version 5.1.4.

    • Update to 5.1.4
    Published Updated
  8. CVE-2023-47109

    Medium · CVSS 5.5EPSS 0.77%Fix available

    PrestaShop blockreassurance BO User can remove any file from server when adding a and deleting a block

    PrestaShop blockreassurance adds an information block aimed at offering helpful information to reassure customers that the store is trustworthy. When adding a block in blockreassurance module, a BO user can modify the http request and give the path of any file in the project instead of an image. When deleting the block from the BO, the file will be deleted. It is possible to make the website completely unavailable by removing index.php for example. This issue has been patched in version 5.1.4.

    • Update to 5.1.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →