p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 183

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-45363

    High · CVSS 7.5EPSS 23.78%Fix available

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    • Update to 1.35.12
    • Update to 1.39.5
    • Update to 1.40.1
    • Update to 1:1.39.5-1
    • Update to 1:1.39.5-1~deb12u1
    Published Updated
  2. CVE-2023-44766

    Medium · CVSS 5.4EPSS 0.6%No fix published

    CVE-2023-44766

    A Cross Site Scripting (XSS) vulnerability in Concrete CMS v.9.2.1 allows an attacker to execute arbitrary code via a crafted script to the SEO - Extra from Page Settings. NOTE: the vendor disputes this because this SEO-related header change can only be made by an admin, and allowing an admin to place JavaScript there is an intentional customization feature.

    Published Updated
  3. DRUPAL-CONTRIB-2023-048

    Not ratedFix available

    DRUPAL-CONTRIB-2023-048

    This module enables users to log in by email address with minimal configurations. Drupal core contains protection against brute force attacks via a flood control mechanism. This module's functionality did not replicate the flood control, enabling brute force attacks. A previous security advisory, [SA-CONTRIB-2023-45](https://www.drupal.org/sa-contrib-2023-045), was released for this issue, but that release did not successfully address the vulnerability. This security advisory and updated module version supersede the previous one.

    • Update to 2.9.0
    Published Updated
  4. GHSA-56fm-hfp3-x3w3

    Medium · CVSS 4.3Fix available

    Wallabag user can disable 2FA unintentionally

    ## Impact wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`. This vulnerability has a CVSSv3.1 score of 4.3. **You should upgrade your instance to version 2.6.7 or higher.** ## Resolution These endpoints now require POST method. ## Credits We would like to thank @dhina016 for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/

    • Update to 2.6.7
    Published Updated
  5. CVE-2023-43655

    Medium · CVSS 6.4EPSS 1.53%Fix available

    Remote Code Execution via web-accessible composer.phar

    Composer is a dependency manager for PHP. Users publishing a composer.phar to a public web-accessible server where the composer.phar can be executed as a php file may be subject to a remote code execution vulnerability if PHP also has `register_argc_argv` enabled in php.ini. Versions 2.6.4, 2.2.22 and 1.10.27 patch this vulnerability. Users are advised to upgrade. Users unable to upgrade should make sure `register_argc_argv` is disabled in php.ini, and avoid publishing composer.phar to the web as this is not best practice.

    • Update to 1.0.0~beta2-1ubuntu0.1~esm2
    • Update to 1.10.1-1ubuntu0.1~esm2
    • Update to 1.10.27
    • Update to 1.6.3-1ubuntu0.1~esm2
    • Update to 2.2.22
    • Update to 2.2.6-2ubuntu4+esm1
    • Update to 2.5.5-1+deb12u4
    • Update to 2.6.4
    • Update to 2.6.4-1
    Published Updated
  6. CVE-2023-5256

    High · CVSS 7.5EPSS 0.85%Fix available

    Drupal core - Critical - Cache poisoning - SA-CORE-2023-006

    In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation. This vulnerability only affects sites with the JSON:API module enabled, and can be mitigated by uninstalling JSON:API. The core REST and contributed GraphQL modules are not affected.

    • Update to 10.0.11
    • Update to 10.1.4
    • Update to 9.5.11
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →