p PatchFirst

PatchFirst · Latest vulnerabilities

wallabag/wallabag vulnerabilities

Vulnerabilities published for wallabag/wallabag in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. GHSA-5pm7-cp8f-p2c2

    Medium · CVSS 4.3Fix available

    wallabag/wallabag Has Multiple Cross-Site Request Forgery (CSRF) Vulnerabilities

    ## Impact wallabag versions prior to 2.6.11 were discovered to contain multiple Cross-Site Request Forgery (CSRF) vulnerabilities across several endpoints. An attacker could craft a malicious link or page that, if visited by a logged-in wallabag user, could trick the user's browser into performing unintended actions within their wallabag account without their consent. Additionally, one endpoint affects the login page locale setting. The affected endpoints allow attackers to potentially perform actions such as: * **Manage API Tokens:** * `/generate-token` * `/revoke-token` * **Manage User Rules:** * `/tagging-rule/delete/{taggin

    • Update to 2.6.11
    Published Updated
  2. GHSA-56fm-hfp3-x3w3

    Medium · CVSS 4.3Fix available

    Wallabag user can disable 2FA unintentionally

    ## Impact wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`. This vulnerability has a CVSSv3.1 score of 4.3. **You should upgrade your instance to version 2.6.7 or higher.** ## Resolution These endpoints now require POST method. ## Credits We would like to thank @dhina016 for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/

    • Update to 2.6.7
    Published Updated
  3. CVE-2023-3566

    Low · CVSS 3.5EPSS 1.37%No fix published

    wallabag Profile Config config allocation of resources

    A vulnerability was found in wallabag 2.5.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /config of the component Profile Config. The manipulation of the argument Name leads to allocation of resources. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-233359. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

    Published Updated
  4. CVE-2018-11352

    Medium · CVSS 4EPSS 0.72%Fix available

    CVE-2018-11352

    The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.

    • Update to 2.3.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →