p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 21

Vulnerabilities published for PHP in the last 30 days: 178. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7190

  1. CVE-2026-80200

    Medium · CVSS 5.3EPSS 0.36%Fix available

    Kimai before 2.53.0 Open Redirect via RelayState

    Kimai before 2.53.0 contains an open redirect vulnerability in the SAML authentication success handler that accepts unvalidated RelayState POST parameters as redirect destinations. Attackers with IdP access can supply malicious RelayState values to redirect authenticated users to attacker-controlled URLs for credential theft or phishing attacks.

    • Update to 2.53.0
    Published Updated
  2. CVE-2026-80199

    Medium · CVSS 6.3EPSS 0.31%Fix available

    Kimai before 2.54.0 Username Enumeration via Timing Oracle

    Kimai before 2.54.0 contains a timing oracle vulnerability in TokenAuthenticator that allows unauthenticated attackers to enumerate valid usernames via X-AUTH-USER header. Attackers can measure response time differences when the password hasher runs only for existing users, enabling username enumeration with no login throttling protection.

    • Update to 2.54.0
    Published Updated
  3. CVE-2026-80198

    High · CVSS 8.7EPSS 0.43%Fix available

    Kimai before 2.56.0 Information Disclosure via config() Twig Function

    Kimai versions before 2.56.0 fail to restrict the config() Twig function in sandboxed invoice and export templates, allowing administrators to access arbitrary configuration keys. Attackers with admin privileges can upload malicious templates to exfiltrate server-wide secrets including LDAP bind passwords and SAML private keys into invoice or export documents accessible to lower-privileged users.

    • Update to 2.56.0
    Published Updated
  4. CVE-2026-80197

    High · CVSS 8.7EPSS 0.26%Fix available

    Kimai before 2.57.0 Improper Authorization via Favorite Endpoints

    Kimai before 2.57.0 contains an improper authorization vulnerability in the favorite timesheet add and remove endpoints that allows authenticated users to manipulate other users' bookmarks. Attackers can add or remove timesheet entries from another user's favorite list by referencing their timesheet identifier, enabling cross-user business-state tampering without administrative privileges.

    • Update to 2.57.0
    Published Updated
  5. CVE-2026-80196

    High · CVSS 8.7EPSS 0.48%Fix available

    Kimai before 2.58.0 Authentication Bypass via Password Reset Link

    Kimai before 2.58.0 contains an authentication bypass vulnerability where password reset links remain valid after password changes because the LoginLink signature covers only the user id, not the password hash. Attackers who intercept or cache a password reset link can use it up to 2 additional times within a 1-hour window to log in as the user even after the legitimate user has changed their password.

    • Update to 2.58.0
    Published Updated
  6. CVE-2026-15916

    Medium · CVSS 4.2EPSS 0.2%Fix available

    Drupal core - Moderately critical - Information disclosure - SA-CORE-2026-010

    Missing Authorization vulnerability in Drupal Drupal core allows Forceful Browsing. This issue affects Drupal core versions: from 0.0.0 to 10.6.13, from 11.3.0 to 11.3.14, from 11.4.0 to 11.4.4, from 0.0.0 to 11.0.*, from 0.0.0 to 11.1.*, from 0.0.0 to 11.2.*.

    • Update to 10.6.13
    • Update to 11.1.0
    • Update to 11.2.0
    • Update to 11.3.0
    • Update to 11.3.14
    • Update to 11.4.4
    Published Updated
  7. CVE-2026-15917

    Medium · CVSS 4.7EPSS 0.21%Fix available

    Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-011

    Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 11.3.0 to 11.3.14, from 11.4.0 to 11.4.4, from 0.0.0 to 11.2.*.

    • Update to 11.3.0
    • Update to 11.3.14
    • Update to 11.4.4
    Published Updated
  8. CVE-2026-55805

    Medium · CVSS 5.4EPSS 0.23%Fix available

    Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-012

    Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Stored XSS. This issue affects Drupal core versions: from 0.0.0 to 10.6.13, from 11.3.0 to 11.3.14, from 11.4.0 to 11.4.4, from 0.0.0 to 11.0.*, from 0.0.0 to 11.1.*, from 0.0.0 to 11.2.*.

    • Update to 10.6.13
    • Update to 11.1.0
    • Update to 11.2.0
    • Update to 11.3.0
    • Update to 11.3.14
    • Update to 11.4.4
    Published Updated
  9. CVE-2026-16638

    Medium · CVSS 6.1EPSS 0.25%Fix available

    Media Folders - Moderately critical - Cross site scripting - SA-CONTRIB-2026-080

    Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Media Folders allows Stored XSS. This issue affects Media Folders versions: from 0.0.0 to 1.0.8.

    • Update to 1.0.8
    Published Updated
  10. CVE-2026-16639

    Critical · CVSS 9.8EPSS 0.64%Fix available

    Internationalization Single Sign-On - Critical - Access bypass - SA-CONTRIB-2026-081

    Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Internationalization Single Sign-On allows Authentication Bypass. This issue affects Internationalization Single Sign-On versions: from 0.0.0 to 1.8.0.

    • Update to 1.8.0
    Published Updated
  11. CVE-2026-16640

    Medium · CVSS 6.1EPSS 0.25%Fix available

    Search API Autocomplete - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-082

    Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Search API Autocomplete allows Reflected XSS. This issue affects Search API Autocomplete versions: from 0.0.0 to 1.12.0.

    • Update to 1.12.0
    Published Updated
  12. CVE-2026-16645

    Critical · CVSS 9.1EPSS 0.4%Fix available

    PhotoSwipe - Responsive JavaScript Modal Image Gallery - Moderately critical - Access bypass - SA-CONTRIB-2026-088

    Missing Authorization vulnerability in Drupal PhotoSwipe - Responsive JavaScript Modal Image Gallery allows Forceful Browsing. This issue affects PhotoSwipe - Responsive JavaScript Modal Image Gallery versions: from 0.0.0 to 3.2.0.

    • Update to 3.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →