p PatchFirst

PatchFirst · Latest vulnerabilities

linux vulnerabilities · Page 20

Vulnerabilities published for linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 514

  1. CVE-2015-5283

    Not ratedEPSS 0.55%Fix available

    CVE-2015-5283

    The sctp_init function in net/sctp/protocol.c in the Linux kernel before 4.2.3 has an incorrect sequence of protocol-initialization steps, which allows local users to cause a denial of service (panic or memory corruption) by creating SCTP sockets before all of the steps have finished.

    • Update to 3.13.0-70.113
    Published Updated
  2. CVE-2015-5156

    Not ratedEPSS 1.03%Fix available

    CVE-2015-5156

    The virtnet_probe function in drivers/net/virtio_net.c in the Linux kernel before 4.2 attempts to support a FRAGLIST feature without proper memory allocation, which allows guest OS users to cause a denial of service (buffer overflow and memory corruption) via a crafted sequence of fragmented packets.

    • Update to 3.13.0-66.108
    Published Updated
  3. CVE-2015-4036

    Not ratedEPSS 0.59%Fix available

    CVE-2015-4036

    Array index error in the tcm_vhost_make_tpg function in drivers/vhost/scsi.c in the Linux kernel before 4.0 might allow guest OS users to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted VHOST_SCSI_SET_ENDPOINT ioctl call. NOTE: the affected function was renamed to vhost_scsi_make_tpg before the vulnerability was announced.

    • Update to 3.13.0-54.91
    Published Updated
  4. CVE-2015-5706

    Not ratedEPSS 0.44%Fix available

    CVE-2015-5706

    Use-after-free vulnerability in the path_openat function in fs/namei.c in the Linux kernel 3.x and 4.x before 4.0.4 allows local users to cause a denial of service or possibly have unspecified other impact via O_TMPFILE filesystem operations that leverage a duplicate cleanup operation.

    • Update to 3.13.0-58.97
    Published Updated
  5. CVE-2015-5366

    Not ratedEPSS 6.08%Fix available

    CVE-2015-5366

    The (1) udp_recvmsg and (2) udpv6_recvmsg functions in the Linux kernel before 4.0.6 provide inappropriate -EAGAIN return values, which allows remote attackers to cause a denial of service (EPOLLET epoll application read outage) via an incorrect checksum in a UDP packet, a different vulnerability than CVE-2015-5364.

    • Update to 3.13.0-58.97
    Published Updated
  6. CVE-2015-4700

    Not ratedEPSS 0.45%Fix available

    CVE-2015-4700

    The bpf_int_jit_compile function in arch/x86/net/bpf_jit_comp.c in the Linux kernel before 4.0.6 allows local users to cause a denial of service (system crash) by creating a packet filter and then loading crafted BPF instructions that trigger late convergence by the JIT compiler.

    • Update to 3.13.0-58.97
    Published Updated
  7. CVE-2015-3291

    Not ratedEPSS 0.4%Fix available

    CVE-2015-3291

    arch/x86/entry/entry_64.S in the Linux kernel before 4.1.6 on the x86_64 platform does not properly determine when nested NMI processing is occurring, which allows local users to cause a denial of service (skipped NMI) by modifying the rsp register, issuing a syscall instruction, and triggering an NMI.

    • Update to 3.13.0-59.98
    Published Updated
  8. CVE-2014-9731

    Not ratedEPSS 0.42%Fix available

    CVE-2014-9731

    The UDF filesystem implementation in the Linux kernel before 3.18.2 does not ensure that space is available for storing a symlink target's name along with a trailing \0 character, which allows local users to obtain sensitive information via a crafted filesystem image, related to fs/udf/symlink.c and fs/udf/unicode.c.

    • Update to 3.13.0-48.80
    Published Updated
  9. CVE-2015-1805

    Not ratedEPSS 1.41%Fix available

    CVE-2015-1805

    The (1) pipe_read and (2) pipe_write implementations in fs/pipe.c in the Linux kernel before 3.16 do not properly consider the side effects of failed __copy_to_user_inatomic and __copy_from_user_inatomic calls, which allows local users to cause a denial of service (system crash) or possibly gain privileges via a crafted application, aka an "I/O vector array overrun."

    • Update to 3.13.0-58.97
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →