p PatchFirst

PatchFirst · Latest vulnerabilities

samba vulnerabilities · Page 3

Vulnerabilities published for samba in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 53

  1. CVE-2015-3223

    Medium · CVSS 5.3EPSS 6.88%Fix available

    CVE-2015-3223

    The ldb_wildcard_compare function in ldb_match.c in ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles certain zero values, which allows remote attackers to cause a denial of service (infinite loop) via crafted packets.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.11
    Published Updated
  2. CVE-2015-0240

    Not ratedEPSS 87.59%Public exploitFix available

    CVE-2015-0240

    The Netlogon server implementation in smbd in Samba 3.5.x and 3.6.x before 3.6.25, 4.0.x before 4.0.25, 4.1.x before 4.1.17, and 4.2.x before 4.2.0rc5 performs a free operation on an uninitialized stack pointer, which allows remote attackers to execute arbitrary code via crafted Netlogon packets that use the ServerPasswordSet RPC API, as demonstrated by packets reaching the _netr_ServerPasswordSet function in rpc_server/netlogon/srv_netlog_nt.c.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.7
    Published Updated
  3. CVE-2014-8143

    Not ratedEPSS 4.26%Fix available

    CVE-2014-8143

    Samba 4.0.x before 4.0.24, 4.1.x before 4.1.16, and 4.2.x before 4.2rc4, when an Active Directory Domain Controller (AD DC) is configured, allows remote authenticated users to set the LDB userAccountControl UF_SERVER_TRUST_ACCOUNT bit, and consequently gain privileges, by leveraging delegation of authority for user-account or computer-account creation.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.4
    Published Updated
  4. CVE-2014-3560

    Not ratedEPSS 56.38%Fix available

    CVE-2014-3560

    NetBIOS name services daemon (nmbd) in Samba 4.0.x before 4.0.21 and 4.1.x before 4.1.11 allows remote attackers to execute arbitrary code via unspecified vectors that modify heap memory, involving a sizeof operation on an incorrect variable in the unstrcpy macro in string_wrappers.h.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.3
    Published Updated
  5. CVE-2014-3493

    Not ratedEPSS 7.27%Fix available

    CVE-2014-3493

    The push_ascii function in smbd in Samba 3.6.x before 3.6.24, 4.0.x before 4.0.19, and 4.1.x before 4.1.9 allows remote authenticated users to cause a denial of service (memory corruption and daemon crash) via an attempt to read a Unicode pathname without specifying use of Unicode, leading to a character-set conversion failure that triggers an invalid pointer dereference.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.2
    Published Updated
  6. CVE-2014-0239

    Not ratedEPSS 66.81%Fix available

    CVE-2014-0239

    The internal DNS server in Samba 4.x before 4.0.18 does not check the QR field in the header section of an incoming DNS message before sending a response, which allows remote attackers to cause a denial of service (CPU and bandwidth consumption) via a forged response packet that triggers a communication loop, a related issue to CVE-1999-0103.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.2
    Published Updated
  7. CVE-2014-0178

    Not ratedEPSS 4.47%Fix available

    CVE-2014-0178

    Samba 3.6.6 through 3.6.23, 4.0.x before 4.0.18, and 4.1.x before 4.1.8, when a certain vfs shadow copy configuration is enabled, does not properly initialize the SRV_SNAPSHOT_ARRAY response field, which allows remote authenticated users to obtain potentially sensitive information from process memory via a (1) FSCTL_GET_SHADOW_COPY_DATA or (2) FSCTL_SRV_ENUMERATE_SNAPSHOTS request.

    • Update to 2:4.1.6+dfsg-1ubuntu2.14.04.2
    Published Updated
  8. CVE-2013-6442

    Not ratedEPSS 4.1%Fix available

    CVE-2013-6442

    The owner_set function in smbcacls.c in smbcacls in Samba 4.0.x before 4.0.16 and 4.1.x before 4.1.6 removes an ACL during use of a --chown or --chgrp option, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging an unintended administrative change.

    • Update to 2:4.1.3+dfsg-2ubuntu4
    Published Updated
  9. CVE-2013-4496

    Not ratedEPSS 9.76%Fix available

    CVE-2013-4496

    Samba 3.x before 3.6.23, 4.0.x before 4.0.16, and 4.1.x before 4.1.6 does not enforce the password-guessing protection mechanism for all interfaces, which makes it easier for remote attackers to obtain access via brute-force ChangePasswordUser2 (1) SAMR or (2) RAP attempts.

    • Update to 2:4.1.3+dfsg-2ubuntu4
    Published Updated
  10. CVE-2013-4408

    Not ratedEPSS 2.75%Fix available

    CVE-2013-4408

    Heap-based buffer overflow in the dcerpc_read_ncacn_packet_done function in librpc/rpc/dcerpc_util.c in winbindd in Samba 3.x before 3.6.22, 4.0.x before 4.0.13, and 4.1.x before 4.1.3 allows remote AD domain controllers to execute arbitrary code via an invalid fragment length in a DCE-RPC packet.

    • Update to 2:4.0.13+dfsg-1ubuntu1
    Published Updated
  11. CVE-2012-6150

    Not ratedEPSS 3.79%Fix available

    CVE-2012-6150

    The winbind_name_list_to_sid_string_list function in nsswitch/pam_winbind.c in Samba through 4.1.2 handles invalid require_membership_of group names by accepting authentication by any user, which allows remote authenticated users to bypass intended access restrictions in opportunistic circumstances by leveraging an administrator's pam_winbind configuration-file mistake.

    • Update to 2:4.0.13+dfsg-1ubuntu1
    Published Updated
  12. CVE-2013-4475

    Not ratedEPSS 9.02%Fix available

    CVE-2013-4475

    Samba 3.2.x through 3.6.x before 3.6.20, 4.0.x before 4.0.11, and 4.1.x before 4.1.1, when vfs_streams_depot or vfs_streams_xattr is enabled, allows remote attackers to bypass intended file restrictions by leveraging ACL differences between a file and an associated alternate data stream (ADS).

    • Update to 2:4.0.13+dfsg-1ubuntu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →