p PatchFirst

PatchFirst · Latest vulnerabilities

gst-plugins-good0.10 vulnerabilities · Page 2

Vulnerabilities published for gst-plugins-good0.10 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 32

  1. CVE-2024-47539

    High · CVSS 8.6EPSS 1.32%No fix published

    GHSL-2024-195: GStreamer has an OOB-write in convert_to_s334_1a

    GStreamer is a library for constructing graphs of media-handling components. An out-of-bounds write vulnerability was identified in the convert_to_s334_1a function in isomp4/qtdemux.c. The vulnerability arises due to a discrepancy between the size of memory allocated to the storage array and the loop condition i * 2 < ccpair_size. Specifically, when ccpair_size is even, the allocated size in storage does not match the loop's expected bounds, resulting in an out-of-bounds write. This bug allows for the overwriting of up to 3 bytes beyond the allocated bounds of the storage array. This vulnerability is fixed in 1.24.10.

    Published Updated
  2. CVE-2024-47537

    High · CVSS 8.6EPSS 0.96%No fix published

    GHSL-2024-094: GStreamer has an OOB-write in isomp4/qtdemux.c

    GStreamer is a library for constructing graphs of media-handling components. The program attempts to reallocate the memory pointed to by stream->samples to accommodate stream->n_samples + samples_count elements of type QtDemuxSample. The problem is that samples_count is read from the input file. And if this value is big enough, this can lead to an integer overflow during the addition. As a consequence, g_try_renew might allocate memory for a significantly smaller number of elements than intended. Following this, the program iterates through samples_count elements and attempts to write samples_count number of elements, potentially exceeding th

    Published Updated
  3. CVE-2023-37327

    High · CVSS 7.6EPSS 1.7%No fix published

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of FLAC audio files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-20775

    Published Updated
  4. CVE-2016-9636

    Critical · CVSS 9.8EPSS 8.33%Fix available

    CVE-2016-9636

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'write count' that goes beyond the initialized buffer.

    • Update to 0.10.31-3+nmu4ubuntu2.16.04.1
    Published Updated
  5. CVE-2016-9635

    Critical · CVSS 9.8EPSS 8.84%Fix available

    CVE-2016-9635

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'skip count' that goes beyond initialized buffer.

    • Update to 0.10.31-3+nmu4ubuntu2.16.04.1
    Published Updated
  6. CVE-2016-9634

    Critical · CVSS 9.8EPSS 8.84%Fix available

    CVE-2016-9634

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via the start_line parameter.

    • Update to 0.10.31-3+nmu4ubuntu2.16.04.1
    Published Updated
  7. CVE-2016-9810

    Medium · CVSS 5.5EPSS 2.37%Fix available

    CVE-2016-9810

    The gst_decode_chain_free_internal function in the flxdex decoder in gst-plugins-good in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via an invalid file, which triggers an incorrect unref call.

    • Update to 0.10.31-3+nmu4ubuntu2.16.04.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →