p PatchFirst

PatchFirst · Latest vulnerabilities

memcached vulnerabilities

Vulnerabilities published for memcached in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2018-1000127

    High · CVSS 7.5EPSS 2.27%Fix available

    CVE-2018-1000127

    memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

    • Update to 1.4.25-2ubuntu1.4
    Published Updated
  2. CVE-2018-1000115

    High · CVSS 7.5EPSS 88.11%Public exploitFix available

    CVE-2018-1000115

    Memcached version 1.5.5 contains an Insufficient Control of Network Message Volume (Network Amplification, CWE-406) vulnerability in the UDP support of the memcached server that can result in denial of service via network flood (traffic amplification of 1:50,000 has been reported by reliable sources). This attack appear to be exploitable via network connectivity to port 11211 UDP. This vulnerability appears to have been fixed in 1.5.6 due to the disabling of the UDP protocol by default.

    • Update to 1.4.25-2ubuntu1.3
    Published Updated
  3. CVE-2017-9951

    High · CVSS 7.5EPSS 4.17%Fix available

    CVE-2017-9951

    The try_read_command function in memcached.c in memcached before 1.4.39 allows remote attackers to cause a denial of service (segmentation fault) via a request to add/set a key, which makes a comparison between signed and unsigned int and triggers a heap-based buffer over-read. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-8705.

    • Update to 1.4.25-2ubuntu1.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →