p PatchFirst

PatchFirst · Latest vulnerabilities

policykit-1 vulnerabilities

Vulnerability published for policykit-1 in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-85498

    Low · CVSS 3.5EPSS 0.26%No fix published

    Polkit: regression in cve-2026-4897 fix (polkit read_cookie()) - stack buffer underflow

    A flaw was found in polkit. When processing input that begins with a null byte, an arithmetic error in the authentication agent helper causes an integer underflow during buffer length calculation, resulting in an out-of-bounds memory read. An attacker capable of supplying crafted input can trigger this flaw, potentially causing an application crash and resulting in a Denial of Service (DoS).

    Published Updated
  2. CVE-2026-4897

    Medium · CVSS 5.5EPSS 0.16%No fix published

    Polkit: polkit: denial of service via unbounded input processing through standard input

    A flaw was found in polkit. A local user can exploit this by providing a specially crafted, excessively long input to the `polkit-agent-helper-1` setuid binary via standard input (stdin). This unbounded input can lead to an out-of-memory (OOM) condition, resulting in a Denial of Service (DoS) for the system.

    Published Updated
  3. CVE-2025-7519

    Medium · CVSS 6.7EPSS 0.22%No fix published

    Polkit: xml policy file with a large number of nested elements may lead to out-of-bounds write

    A flaw was found in polkit. When processing an XML policy with 32 or more nested elements in depth, an out-of-bounds write can be triggered. This issue can lead to a crash or other unexpected behavior, and arbitrary code execution is not discarded. To exploit this flaw, a high-privilege account is needed as it's required to place the malicious policy file properly.

    Published Updated
  4. CVE-2021-4034

    High · CVSS 7.8EPSS 94.92%In KEVPublic exploitFix available

    CVE-2021-4034

    A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count correctly and ends trying to execute environment variables as commands. An attacker can leverage this by crafting environment variables in such a way it'll induce pkexec to execute arbitrary code. When successfully executed the attack can cause a local privilege escalation given unprivileged users administrative rights on the target machine.

    • Update to 0.105-20ubuntu0.18.04.6
    Published Updated
  5. CVE-2019-6133

    Medium · CVSS 6.7EPSS 0.45%Fix available

    CVE-2019-6133

    In PolicyKit (aka polkit) 0.115, the "start time" protection mechanism can be bypassed because fork() is not atomic, and therefore authorization decisions are improperly cached. This is related to lack of uid checking in polkitbackend/polkitbackendinteractiveauthority.c.

    • Update to 0.105-20ubuntu0.18.04.5
    Published Updated
  6. CVE-2018-1116

    Medium · CVSS 4.7EPSS 1.2%Fix available

    CVE-2018-1116

    A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

    • Update to 0.105-20ubuntu0.18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →