p PatchFirst

PatchFirst · Latest vulnerabilities

libarchive vulnerabilities

Vulnerabilities published for libarchive in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. CVE-2025-25724

    Medium · CVSS 4EPSS 0.37%Fix available

    CVE-2025-25724

    list_item_verbose in tar/util.c in libarchive through 3.7.7 does not check an strftime return value, which can lead to a denial of service or unspecified other impact via a crafted TAR archive that is read with a verbose value of 2. For example, the 100-byte buffer may not be sufficient for a custom locale.

    • Update to 3.4.0-2ubuntu1.5
    Published Updated
  2. CVE-2022-36227

    Critical · CVSS 9.8EPSS 2.44%Fix available

    CVE-2022-36227

    In libarchive before 3.6.2, the software does not check for an error after calling calloc function that can return with a NULL pointer if the function fails, which leads to a resultant NULL pointer dereference. NOTE: the discoverer cites this CWE-476 remark but third parties dispute the code-execution impact: "In rare circumstances, when NULL is equivalent to the 0x0 memory address and privileged code can access it, then writing or reading memory is possible, which may lead to code execution."

    • Update to 3.4.0-2ubuntu1.3
    Published Updated
  3. CVE-2021-31566

    High · CVSS 7.8EPSS 0.39%Fix available

    CVE-2021-31566

    An improper link resolution flaw can occur while extracting an archive leading to changing modes, times, access control lists, and flags of a file outside of the archive. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to gain more privileges in a system.

    • Update to 3.4.0-2ubuntu1.1
    Published Updated
  4. CVE-2021-23177

    High · CVSS 7.8EPSS 0.39%Fix available

    CVE-2021-23177

    An improper link resolution flaw while extracting an archive can lead to changing the access control list (ACL) of the target of the link. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to change the ACL of a file on the system and gain more privileges.

    • Update to 3.4.0-2ubuntu1.1
    Published Updated
  5. CVE-2022-28066

    Medium · CVSS 5.5Fix available

    UBUNTU-CVE-2022-28066

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2022-26280. Reason: This candidate is a duplicate of CVE-2022-26280. Notes: All CVE users should reference CVE-2022-26280 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Update to 3.4.0-2ubuntu1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →