p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 3

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 86

  1. CVE-2022-21661

    High · CVSS 8EPSS 97.8%Public exploitNo fix published

    SQL injection in WordPress

    WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.

    Published Updated
  2. CVE-2021-44223

    High · CVSS 8.1EPSS 28.98%No fix published

    CVE-2021-44223

    WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

    Published Updated
  3. CVE-2021-39203

    Medium · CVSS 6.8EPSS 0.94%No fix published

    Private data disclosure/privilege escalation through the block editor in Wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions authenticated users who don't have permission to view private post types/data can bypass restrictions in the block editor under certain conditions. This affected WordPress 5.8 beta during the testing period. It's fixed in the final 5.8 release.

    Published Updated
  4. CVE-2021-39202

    High · CVSS 7.6EPSS 0.82%No fix published

    WordPress 5.8 beta: Stored Cross-Site Scripting (XSS) vulnerability in widget

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions the widgets editor introduced in WordPress 5.8 beta 1 has improper handling of HTML input in the Custom HTML feature. This leads to stored XSS in the custom HTML widget. This has been patched in WordPress 5.8. It was only present during the testing/beta phase of WordPress 5.8.

    Published Updated
  5. CVE-2021-39201

    High · CVSS 7.6EPSS 1.49%No fix published

    Authenticated cross-site scripting (XSS) in WordPress editor

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/repo

    Published Updated
  6. CVE-2021-39200

    Medium · CVSS 5.3EPSS 1.97%No fix published

    Information Disclosure in wp_die() via JSONP in wordpress

    WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

    Published Updated
  7. CVE-2021-29450

    Medium · CVSS 6.5EPSS 2.09%No fix published

    WordPress Authenticated disclosure of password-protected posts and pages

    Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

    Published Updated
  8. CVE-2021-29447

    High · CVSS 7.1EPSS 85.72%Public exploitNo fix published

    WordPress Authenticated XXE attack when installation is running PHP 8

    Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

    Published Updated
  9. CVE-2020-4047

    Medium · CVSS 6.8EPSS 3.27%No fix published

    Authenticated XSS via media attachment page in WordPress

    In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →