p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 2

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 32

  1. CVE-2024-33871

    High · CVSS 8.8EPSS 1.43%Fix available

    CVE-2024-33871

    An issue was discovered in Artifex Ghostscript before 10.03.1. contrib/opvp/gdevopvp.c allows arbitrary code execution via a custom Driver library, exploitable via a crafted PostScript document. This occurs because the Driver parameter for opvp (and oprp) devices can have an arbitrary name for a dynamic library; this library is then loaded.

    • Update to 10.02.1~dfsg1-0ubuntu7.1
    Published Updated
  2. CVE-2024-33870

    Medium · CVSS 6.3EPSS 0.52%Fix available

    CVE-2024-33870

    An issue was discovered in Artifex Ghostscript before 10.03.1. There is path traversal (via a crafted PostScript document) to arbitrary files if the current directory is in the permitted paths. For example, there can be a transformation of ../../foo to ./../../foo and this will grant access if ./ is permitted.

    • Update to 10.02.1~dfsg1-0ubuntu7.1
    Published Updated
  3. CVE-2024-33869

    Medium · CVSS 5.3EPSS 0.45%Fix available

    CVE-2024-33869

    An issue was discovered in Artifex Ghostscript before 10.03.1. Path traversal and command execution can occur (via a crafted PostScript document) because of path reduction in base/gpmisc.c. For example, restrictions on use of %pipe% can be bypassed via the aa/../%pipe%command# output filename.

    • Update to 10.02.1~dfsg1-0ubuntu7.1
    Published Updated
  4. CVE-2024-29511

    High · CVSS 7.5EPSS 1.14%Fix available

    CVE-2024-29511

    Artifex Ghostscript before 10.03.1, when Tesseract is used for OCR, has a directory traversal issue that allows arbitrary file reading (and writing of error messages to arbitrary files) via OCRLanguage. For example, exploitation can use debug_file /tmp/out and user_patterns_file /etc/passwd.

    • Update to 10.02.1~dfsg1-0ubuntu7.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →