p PatchFirst

PatchFirst · Latest vulnerabilities

pillow vulnerabilities

Vulnerabilities published for pillow in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2026-42311

    High · CVSS 8.6EPSS 0.15%Fix available

    Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

    Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

    • Update to 11.3.0-1ubuntu1.3
  2. CVE-2026-42310

    Medium · CVSS 5.1EPSS 0.17%Fix available

    Pillow: PDF Parsing Trailer Infinite Loop (DoS)

    Pillow is a Python imaging library. From version 4.2.0 to before version 12.2.0, an attacker can supply a malicious PDF that causes the process to hang indefinitely, consuming 100% CPU and making the application unresponsive. This issue has been patched in version 12.2.0.

    • Update to 11.3.0-1ubuntu1.3
  3. CVE-2026-42308

    Medium · CVSS 5.1EPSS 0.11%Fix available

    Pillow: Integer overflow when processing fonts

    Pillow is a Python imaging library. Prior to version 12.2.0, if a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This issue has been patched in version 12.2.0.

    • Update to 11.3.0-1ubuntu1.3
  4. CVE-2026-42309

    Medium · CVSS 5.1EPSS 0.13%Fix available

    Pillow: Heap buffer overflow with nested list coordinates

    Pillow is a Python imaging library. From version 11.2.1 to before version 12.2.0, passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This issue has been patched in version 12.2.0.

    • Update to 11.3.0-1ubuntu1.3
  5. CVE-2026-40192

    High · CVSS 8.7EPSS 0.67%Fix available

    Pillow is vulnerable to a FITS GZIP decompression bomb

    Pillow is a Python imaging library. Versions 10.3.0 through 12.1.1 did not limit the amount of GZIP-compressed data read when decoding a FITS image, making them vulnerable to decompression bomb attacks. A specially crafted FITS file could cause unbounded memory consumption, leading to denial of service (OOM crash or severe performance degradation). If users are unable to immediately upgrade, they should only open specific image formats, excluding FITS, as a workaround.

    • Update to 11.3.0-1ubuntu1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →