p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities · Page 3

Vulnerabilities published for glibc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 48

  1. CVE-2016-10739

    Medium · CVSS 5.3EPSS 0.48%No fix published

    CVE-2016-10739

    In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.

    Published Updated
  2. CVE-2019-6488

    High · CVSS 7.8EPSS 0.45%No fix published

    CVE-2019-6488

    The string component in the GNU C Library (aka glibc or libc6) through 2.28, when running on the x32 architecture, incorrectly attempts to use a 64-bit register for size_t in assembly codes, which can lead to a segmentation fault or possibly unspecified other impact, as demonstrated by a crash in __memmove_avx_unaligned_erms in sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S during a memcpy.

    Published Updated
  3. CVE-2016-10228

    Medium · CVSS 5.9EPSS 4.11%Fix available

    CVE-2016-10228

    The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.

    • Update to 2.23-0ubuntu11.3+esm3
    Published Updated
  4. CVE-2010-3192

    Not ratedEPSS 1.61%No fix published

    CVE-2010-3192

    Certain run-time memory protection mechanisms in the GNU C Library (aka glibc or libc6) print argv[0] and backtrace information, which might allow context-dependent attackers to obtain sensitive information from process memory by executing an incorrect program, as demonstrated by a setuid program that contains a stack-based buffer overflow error, related to the __fortify_fail function in debug/fortify_fail.c, and the __stack_chk_fail (aka stack protection) and __chk_fail (aka FORTIFY_SOURCE) implementations.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →