p PatchFirst

PatchFirst · Latest vulnerabilities

nss vulnerabilities

Vulnerability published for nss in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2023-4421

    Medium · CVSS 6.5EPSS 0.76%No fix published

    CVE-2023-4421

    The NSS code used for checking PKCS#1 v1.5 was leaking information useful in mounting Bleichenbacher-like attacks. Both the overall correctness of the padding as well as the length of the encrypted message was leaking through timing side-channel. By sending large number of attacker-selected ciphertexts, the attacker would be able to decrypt a previously intercepted PKCS#1 v1.5 ciphertext (for example, to decrypt a TLS session that used RSA key exchange), or forge a signature using the victim's key. The issue was fixed by implementing the implicit rejection algorithm, in which the NSS returns a deterministic random message in case invalid padd

    Published Updated
  2. CVE-2022-22747

    Medium · CVSS 6.5EPSS 0.67%Fix available

    CVE-2022-22747

    After accepting an untrusted certificate, handling an empty pkcs7 sequence as part of the certificate data could have lead to a crash. This crash is believed to be unexploitable. This vulnerability affects Firefox ESR < 91.5, Firefox < 96, and Thunderbird < 91.5.

    • Update to 2:3.28.4-0ubuntu0.16.04.14+esm3
    Published Updated
  3. CVE-2021-43527

    Critical · CVSS 9.8EPSS 17.56%Fix available

    CVE-2021-43527

    NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signatures encoded within CMS, S/MIME, PKCS \#7, or PKCS \#12 are likely to be impacted. Applications using NSS for certificate validation or other TLS, X.509, OCSP or CRL functionality may be impacted, depending on how they configure NSS. *Note: This vulnerability does NOT impact Mozilla Firefox.* However, email clients and PDF viewers that use NSS for signature verification, such as Thunderbird, LibreOffice, Evolution and Evince are believed to be impa

    • Update to 2:3.28.4-0ubuntu0.16.04.14+esm2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →