p PatchFirst

CVE-2020-11022

CVE-2020-11022 · jQuery has a potential XSS vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS 6.9 · Medium · EPSS 99.2% · Public exploit · Fix available

Published
Updated

Stack: system · php · node

Affected products and versions

  • jquery

    Versions
    • >= 1.12.0, < 3.5.0: Affected

    No fix published

  • node-jquery Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Update to 3.5.0+dfsg-2

  • node-jquery Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Update to 3.5.0+dfsg-2

  • node-jquery Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Update to 3.5.0+dfsg-2

  • znc Debian:12

    Versions
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.8.2-3.1
    • 1.8.2-3.1+deb12u1
    • 1.8.2-4
    • 1.9.0-1
    • 1.9.0-2
    • 1.9.1-1
    • 1.9.1-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • znc Debian:13

    Versions
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.9.1-2
    • 1.9.1-2+deb13u1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • znc Debian:14

    Versions
    • 1.10.1-1
    • 1.10.2-1
    • 1.9.1-2
    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • jquery npm

    Affected ranges
    • SEMVER: ≥ 1.12.0, < 3.5.0

    Update to 3.5.0

  • jquery NuGet

    Versions
    • 1.12.0
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 2.0.0
    • 2.0.1
    • 2.0.1.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0.1
    • 3.1.0
    • 3.1.1
    • 3.2.1
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.12.0, < 3.5.0

    Update to 3.5.0

  • jquery-rails RubyGems

    Versions
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 1.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.12
    • 1.0.13
    • 1.0.14
    • 1.0.15
    • 1.0.16
    • 1.0.17
    • 1.0.18
    • 1.0.19
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.0.rc
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.1.5
    • 4.0.0
    • 4.0.0.beta1
    • 4.0.0.beta2
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.1.0
    • 4.1.1
    • 4.2.0
    • 4.2.1
    • 4.2.2
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.3.3
    • 4.3.4
    • 4.3.5
    Affected ranges
    • ECOSYSTEM: < 4.4.0

    Update to 4.4.0

  • org.webjars.npm:jquery Maven

    Versions
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 2.1.0
    • 2.1.1
    • 2.1.1-rc1
    • 2.1.1-rc2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0-alpha1
    • 3.0.0-beta1
    • 3.0.0-rc1
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.12.0, < 3.5.0

    Update to 3.5.0

  • maximebf/debugbar Packagist

    Versions
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.1
    • 1.10.0
    • 1.10.1
    • 1.13.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.5.1
    • 1.6
    • 1.6.1
    • 1.7
    • 1.7.1
    • 1.8
    • 1.9
    • 1.9.1
    • 1.9.10
    • 1.9.11
    • 1.9.12
    • 1.9.13
    • 1.9.14
    • 1.9.15
    • 1.9.2
    • 1.9.3
    • 1.9.4
    • 1.9.5
    • 1.9.6
    • 1.9.7
    • 1.9.8
    • 1.9.9
    • v1.10.2
    • v1.10.3
    • v1.10.4
    • v1.10.5
    • v1.11.0
    • v1.11.1
    • v1.12.0
    • v1.13.0
    • v1.14.0
    • v1.14.1
    • v1.15.0
    • v1.15.1
    • v1.16.0
    • v1.16.1
    • v1.16.2
    • v1.16.3
    • v1.16.4
    • v1.16.5
    • v1.17.0
    • v1.17.1
    • v1.17.2
    • v1.17.3
    • v1.18.0
    • v1.18.1
    • v1.18.2
    Affected ranges
    • ECOSYSTEM: < 1.19.0

    Update to 1.19.0

  • athlon1600/youtube-downloader Packagist

    Versions
    • v1.0.0
    • v1.0.1
    • v2.0.0
    • v2.0.1
    • v2.0.2
    • v2.0.3
    • v2.0.4
    • v2.0.5
    • v2.0.6
    • v2.0.7
    • v2.0.8
    • v2.0.9
    • v2.1.0
    • v2.1.1
    • v2.1.2
    • v3.0.0
    • v3.0.1
    • v3.0.2
    • v3.1.0
    • v3.1.1
    • v3.1.2
    • v4.0.0
    Affected ranges
    • ECOSYSTEM: < 4.0.1

    Update to 4.0.1

  • components/jquery Packagist

    Versions
    • 1.12.0
    • 1.12.1
    • 1.12.4
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.4
    • 3.0.0
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.1
    • 3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.12.0, < 3.5.0

    Update to 3.5.0

  • drupal7 Ubuntu:Pro:14.04:LTS

    Versions
    • 7.23-1
    • 7.24-1
    • 7.24-2
    • 7.26-1
    • 7.26-1ubuntu0.1
    • 7.26-1ubuntu0.1+esm1
    • 7.26-1ubuntu0.1+esm2
    Affected ranges
    • ECOSYSTEM: < 7.26-1ubuntu0.1+esm3

    Update to 7.26-1ubuntu0.1+esm3

  • jquery Ubuntu:Pro:16.04:LTS

    Versions
    • 1.7.2+dfsg-3ubuntu2
    • 1.11.3+dfsg-4
    Affected ranges
    • ECOSYSTEM: < 1.11.3+dfsg-4ubuntu0.1~esm1

    Update to 1.11.3+dfsg-4ubuntu0.1~esm1

  • drupal7 Ubuntu:Pro:16.04:LTS

    Versions
    • 7.38-1
    • 7.41-1
    • 7.44-1ubuntu1~16.04.0
    • 7.44-1ubuntu1~16.04.0+esm1
    • 7.44-1ubuntu1~16.04.0+esm2
    Affected ranges
    • ECOSYSTEM: < 7.44-1ubuntu1~16.04.0+esm3

    Update to 7.44-1ubuntu1~16.04.0+esm3

  • jquery Ubuntu:Pro:18.04:LTS

    Versions
    • 3.1.1-2
    • 3.2.1-1
    Affected ranges
    • ECOSYSTEM: < 3.2.1-1ubuntu0.1~esm1

    Update to 3.2.1-1ubuntu0.1~esm1

  • jquery Ubuntu:20.04:LTS

    Versions
    • 3.3.1~dfsg-3
    Affected ranges
    • ECOSYSTEM: < 3.3.1~dfsg-3ubuntu0.1

    Update to 3.3.1~dfsg-3ubuntu0.1

Original sources

Check your server →