p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in vrana/adminer

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für vrana/adminer: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 8

  1. CVE-2026-25892

    Hoch · CVSS 7.5EPSS 1,72%Öffentlicher ExploitKorrektur verfügbar

    Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint

    Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

    • Auf 5.4.2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-43960

    Hoch · CVSS 8.6EPSS 0,73%Keine Korrektur veröffentlicht

    CVE-2025-43960

    Adminer 4.8.1, when using Monolog for logging, allows a Denial of Service (memory consumption) via a crafted serialized payload (e.g., using s:1000000000), leading to a PHP Object Injection issue. Remote, unauthenticated attackers can trigger this by sending a malicious serialized object, which forces excessive memory usage, rendering Adminer’s interface unresponsive and causing a server-level DoS. While the server may recover after several minutes, multiple simultaneous requests can cause a complete crash requiring manual intervention.

    Veröffentlicht Aktualisiert
  3. CVE-2021-29625

    Hoch · CVSS 7.5EPSS 9,57%Öffentlicher ExploitKorrektur verfügbar

    XSS in doc_link

    Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PH

    • Auf 4.8.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2021-21311

    Hoch · CVSS 7.2EPSS 98,46%Im KEV-KatalogÖffentlicher ExploitKorrektur verfügbar

    SSRF in adminer

    Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

    • Auf 4.7.9 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →