p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in yiisoft/yii

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für yiisoft/yii: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2025-32027

    Mittel · CVSS 6.1EPSS 0,24%Korrektur verfügbar

    Yii does not prevent XSS in scenarios where fallback error renderer is used

    Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

    • Auf 1.1.31 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-47130

    Hoch · CVSS 8.1EPSS 3,15%Korrektur verfügbar

    Unsafe deserialization of user data in yiisoft/yii

    Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Auf 1.1.29 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-41922

    Hoch · CVSS 8.1EPSS 1,25%Korrektur verfügbar

    yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input

    `yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.

    • Auf 1.1.27 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2014-4672

    Nicht bewertetEPSS 2,12%Korrektur verfügbar

    CVE-2014-4672

    The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the value property.

    • Auf 1.1.15 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →