p PatchFirst

CVE-2021-35940

CVE-2021-35940 · Regression of CVE-2017-12613

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

CVSS 7.1 · High · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache portable runtime (apr)

    Versions
    • Apache Portable Runtime 1.7.0: Affected

    No fix published

  • apr Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.7.0-7

    Update to 1.7.0-7

  • apr Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.7.0-7

    Update to 1.7.0-7

  • apr Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.7.0-7

    Update to 1.7.0-7

  • apr Ubuntu:Pro:14.04:LTS

    Versions
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    Affected ranges
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1

    Update to 1.5.0-1ubuntu0.1~esm1

  • apr Ubuntu:Pro:16.04:LTS

    Versions
    • 1.5.2-3
    Affected ranges
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm1

    Update to 1.5.2-3ubuntu0.1~esm1

  • apr Ubuntu:22.04:LTS

    Affected ranges
    • ECOSYSTEM: < 1.7.0-6ubuntu1

    Update to 1.7.0-6ubuntu1

Original sources

Check your server →