p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de spice

Vulnerabilidades publicadas para spice en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 13

  1. CVE-2019-3813

    Alta · CVSS 7.5EPSS 1,21%Corrección disponible

    CVE-2019-3813

    Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.8
    Publicación Actualización
  2. CVE-2018-10873

    Alta · CVSS 8.3EPSS 3,93%Corrección disponible

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.7
    Publicación Actualización
  3. CVE-2016-9577

    Alta · CVSS 7.5EPSS 3,79%Corrección disponible

    CVE-2016-9577

    A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.4
    Publicación Actualización
  4. CVE-2017-12194

    Crítica · CVSS 9.8EPSS 5,25%Corrección disponible

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.6
    Publicación Actualización
  5. CVE-2016-0749

    Crítica · CVSS 9.8EPSS 8,49%Corrección disponible

    CVE-2016-0749

    The smartcard interaction in SPICE allows remote attackers to cause a denial of service (QEMU-KVM process crash) or possibly execute arbitrary code via vectors related to connecting to a guest VM, which triggers a heap-based buffer overflow.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.3
    Publicación Actualización
  6. CVE-2015-5260

    Alta · CVSS 7.8EPSS 0,55%Corrección disponible

    CVE-2015-5260

    Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via QXL commands related to the surface_id parameter.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.2
    Publicación Actualización
  7. CVE-2015-3247

    Sin evaluarEPSS 1,14%Corrección disponible

    CVE-2015-3247

    Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.

    • Actualiza a 0.12.4-0nocelt2ubuntu1.1
    Publicación Actualización
  8. CVE-2013-4130

    Sin evaluarEPSS 2,63%Corrección disponible

    CVE-2013-4130

    The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.

    • Actualiza a 0.12.4-0nocelt1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →