p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in spice

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für spice: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 13

  1. CVE-2019-3813

    Hoch · CVSS 7.5EPSS 1,21%Korrektur verfügbar

    CVE-2019-3813

    Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

    • Auf 0.12.4-0nocelt2ubuntu1.8 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-10873

    Hoch · CVSS 8.3EPSS 3,93%Korrektur verfügbar

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Auf 0.12.4-0nocelt2ubuntu1.7 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2016-9577

    Hoch · CVSS 7.5EPSS 3,79%Korrektur verfügbar

    CVE-2016-9577

    A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.

    • Auf 0.12.4-0nocelt2ubuntu1.4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2017-12194

    Kritisch · CVSS 9.8EPSS 5,25%Korrektur verfügbar

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Auf 0.12.4-0nocelt2ubuntu1.6 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2016-0749

    Kritisch · CVSS 9.8EPSS 8,49%Korrektur verfügbar

    CVE-2016-0749

    The smartcard interaction in SPICE allows remote attackers to cause a denial of service (QEMU-KVM process crash) or possibly execute arbitrary code via vectors related to connecting to a guest VM, which triggers a heap-based buffer overflow.

    • Auf 0.12.4-0nocelt2ubuntu1.3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2015-5260

    Hoch · CVSS 7.8EPSS 0,55%Korrektur verfügbar

    CVE-2015-5260

    Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via QXL commands related to the surface_id parameter.

    • Auf 0.12.4-0nocelt2ubuntu1.2 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2015-3247

    Nicht bewertetEPSS 1,14%Korrektur verfügbar

    CVE-2015-3247

    Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.

    • Auf 0.12.4-0nocelt2ubuntu1.1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2013-4130

    Nicht bewertetEPSS 2,63%Korrektur verfügbar

    CVE-2013-4130

    The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.

    • Auf 0.12.4-0nocelt1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →